Jump to content

  • Log In with Google      Sign In   
  • Create Account





Day 14 – Blender, Unity and Normals bug

Posted by Alex.SilR, in General 06 November 2012 · 525 views

Mirrored from my blog (en, pt-br).

Today I basically kept doing the geometric model game and imported it to Unity.

What I did today was make the UV mapping of the pieces and some renders. Today I just didn’t see the second part of the video lesson I wanted, but gave to practice in Blender.

Posted Image

http://www.youtube.com/watch?v=_CXSyol-EZE&feature=player_embedded

http://www.youtube.com/watch?v=S4YSEHDiTII&feature=player_embedded

http://www.youtube.com/watch?v=QhEmHJzTfYY&feature=player_embedded

http://www.youtube.com/watch?v=q_SZwxM_-hY&feature=player_embedded

http://www.youtube.com/watch?v=9hAHx745lmk&feature=player_embedded

After I finished UV mapping of the entire model I did the import into Unity by the Blender file. The parts imported all right, I just had a problem with the main cube. It stayed with the Normals wrong.

Posted Image

I thought that was why I did not give a Ctrl + N to normalize Normals. I did it, and continued reimported the error. I thought if I made the Normal map (by the way I found a very good tutorial) would solve the problem, and I did not solved. In fact got worse.

Posted Image

After giving a look around in the settings, I saw that the import normals option was set to import, I changed the option to Calculate and it worked.

Posted Image

If you want to see how the model was inside the Unity click here (online).

Tomorrow (Monday) and Tuesday I’ll have to take a break to do some things in college, but Wednesday I start again.

PS: Sorry for the bad english.






July 2016 »

S M T W T F S
     1 2
3456789
10111213141516
17181920212223
24252627282930
31      

Recent Entries

PARTNERS