Jump to content

  • Log In with Google      Sign In   
  • Create Account

FREE SOFTWARE GIVEAWAY

We have 4 x Pro Licences (valued at $59 each) for 2d modular animation software Spriter to give away in this Thursday's GDNet Direct email newsletter.


Read more in this forum topic or make sure you're signed up (from the right-hand sidebar on the homepage) and read Thursday's newsletter to get in the running!






Computers...

Posted by JD_Rushing, 31 October 2013 · 382 views

glReadPixels
So I cloned my main hard drive over to a bigger one and then extended the partition. Everything seemed fine the first day. I even programmed more. I have been working a lot at my sad non-computer based job so not much programming. I have been working on a multi-branching menu GUIObject. It was working....then the new(er) hard drive had a meltdown and windows went nuts. So we had to put the old hard drive in. I lost only a little bit of programming...and am somehow now not programming the menu right. For some reason glReadPixels reads the menu object as a whole entity. Then inside the menu object, I redraw the menu only, with each button and item inside having its own color. Now it is only reading the background color. Quite frustrating. It was SO much simplier when I did everything has a bounding box and checked if the mouse position was in or out of the box. But I want the possibility of interesting shapes for the GUIObjects so I am determined.

Still frustrated...

[Edit]
Decided to do a screw it. I figured it down the me trying to redo the frame/screen in which the menu object is located. Basically clear the area and redo the viewport. For some reason, this was messing up thing, because when I removed the code it started working just fine. So for now I am moving on, and will come back to it if I need to.




December 2014 »

S M T W T F S
 123456
78910111213
14151617181920
2122232425 26 27
28293031   

Recent Entries

Recent Comments

PARTNERS