Jump to content

  • Log In with Google      Sign In   
  • Create Account


#ActualGaiiden

Posted 06 August 2012 - 02:48 PM

Now I notice that the article submitting page uses the same editor as the forum posts do and that this editor doesn't allow me to edit the raw HTML code. Is there any way to import HTML or will I have to copy it, paragraph by paragraph, and apply formatting to it?


Currently this is not possible, although I believe it's mainly due to a restriction placed on your account since you are not a mod or staff member. I know the ability to post articles using HTML is there, we just have to 1) ensure that doing so won't create an exploit malicious users can take advantage of to damage the site and 2) check that it's possible to enable for articles only and not only articles and forum posting together. I'll get back to you.

Copy & paste from a browser into this editor breaks the formatting as well...


I've noticed this too recently and I'm not sure why. I know in the past I was able to paste RTF into the editor box - although to be honest it usually caused more trouble than not - I would sometimes paste some text copied from Word and it would show up in a slightly larger font all bold for some reason. Or I would paste the RTF content and then publish and some of the formatting wouldn't turn up properly when I viewed the post. I'm not sure if an update changed this or not. I can check on that too

#1Gaiiden

Posted 06 August 2012 - 02:47 PM

Now I notice that the article submitting page uses the same editor as the forum posts do and that this editor doesn't allow me to edit the raw HTML code. Is there any way to import HTML or will I have to copy it, paragraph by paragraph, and apply formatting to it?

Currently this is not possible, although I believe it's mainly due to a restriction placed on your account since you are not a mod or staff member. I know the ability to post articles using HTML is there, we just have to 1) ensure that doing so won't create an exploit malicious users can take advantage of to damage the site and 2) check that it's possible to enable for articles only and not only articles and forum posting together. I'll get back to you.

Copy & paste from a browser into this editor breaks the formatting as well...

I've noticed this too recently and I'm not sure why. I know in the past I was able to paste RTF into the editor box - although to be honest it usually caused more trouble than not - I would sometimes paste some text copied from Word and it would show up in a slightly larger font all bold for some reason. Or I would paste the RTF content and then publish and some of the formatting wouldn't turn up properly when I viewed the post. I'm not sure if an update changed this or not. I can check on that too

PARTNERS