Jump to content

  • Log In with Google      Sign In   
  • Create Account


#ActualEusKoder

Posted 07 September 2012 - 05:00 PM

Hello,
I am developing a game using Visual Studio 2010 and XNA 4.0,
after advancing to some extent with the project (a platform based 2d platformer msdn starter kit) I got to test it on different computers with different hardware (CPU, graphics, etc.) and I found that the speed of movement object of the game is quite different, I implemented the PSK physics msdn that are based on time,

		/// <summary>
		/// Updates the player's velocity and position based on input, gravity, etc.
		/// </summary>
		public void ApplyPhysics(GameTime gameTime)
		{
			float elapsed = (float)gameTime.ElapsedGameTime.TotalSeconds;
			Vector2 previousPosition = Position;
			// Base velocity is a combination of horizontal movement control and
			// acceleration downward due to gravity.
			velocity.X += movement * MoveAcceleration * elapsed;
			velocity.Y = MathHelper.Clamp(velocity.Y + GravityAcceleration * elapsed, -MaxFallSpeed, MaxFallSpeed);
			velocity.Y = DoJump(velocity.Y, gameTime);
		  
			// Apply pseudo-drag horizontally.
			if (IsOnGround)
				velocity.X *= GroundDragFactor;
			else
				velocity.X *= GroundDragFactor;
				//velocity.X *= AirDragFactor;
			// Prevent the player from running faster than his top speed.		  
			velocity.X = MathHelper.Clamp(velocity.X, -MaxMoveSpeed, MaxMoveSpeed);
			// Apply velocity.
			Position += velocity *elapsed;
			Position = new Vector2((float)Math.Round(Position.X), (float)Math.Round(Position.Y));
		  
			// If the player is now colliding with the level, separate them.
			HandleCollisions(gameTime);
			// If the collision stopped us from moving, reset the velocity to zero.
			if (Position.X == previousPosition.X)
				velocity.X = 0;
			if (Position.Y == previousPosition.Y)
			{
				velocity.Y = 0;
				jumpTime = 0.0f;
			}
		}

tested eg with a PC (PC1) 2.13GHz Intel Core 2 6400 / ATI Radeon HD 4670
and another one: (pc2) 3.00GHz Intel Pentium D / Intel 82945G Express Chipset Family
by displacement difference (moving x axis at supossed (position = velocity * gametime.ElapsedGameTime.TotalSeconds) constant velocity, for example) is 3 seconds in a total of 20 (example: moving pc1 player sprite 6000 pixels in the x-axis at 20 seconds and pc 2 runs the same distance in 17 ).
Tested on a 3rd PC: i72700k / Gigabyte GTX 560 TI
the results are even worse, after some time after starting the game gets like 3 times slower and showing the number of pixels in each frame moved in a debug window in the game (counting updatespersecond with counter variable for updates cuantity and gametime for counting a second show 63fps), it appears as if the number is always constant ( refreshments lose the Update method?).
In this pc if I put the game in fullscreen during the course of the game, the effect of "go slow" is immediate and restore window mode sometimes yield returns to "normal" and sometimes not.
Eventually I began to try a new project to test whether the movement is constant in different pc loading only one sprite and its position value in screen printing.
Occur The same.
I even tried moving a constant amount of pixels explicitly (position + = 5) and different speeds in different pc quantities of pixels moved in x time.
I have the game loop as the default (fixedTimeStep = true ;).
I've also tried turning off and creating another timestep as discussed in different post (eg http://gafferongames...-your-timestep/
but i can´t achieve the desired result, move the same number of pixels in X seconds on different computers with windows.
All pc used for tests use windows 7 enterprise pc1 == x86 the others are x64.

The weirdest thing is that I find information about people describing the same problem and that I wear long nights of searches.

Thanks for your help.

#2EusKoder

Posted 07 September 2012 - 08:33 PM

Hello,
I am developing a game using Visual Studio 2010 and XNA 4.0,
after advancing to some extent with the project (a platform based 2d platformer msdn starter kit) I got to test it on different computers with different hardware (CPU, graphics, etc.) and I found that the speed of movement object of the game is quite different, I implemented the PSK physics msdn that are based on time,

	    /// <summary>
	    /// Updates the player's velocity and position based on input, gravity, etc.
	    /// </summary>
	    public void ApplyPhysics(GameTime gameTime)
	    {
		    float elapsed = (float)gameTime.ElapsedGameTime.TotalSeconds;
		    Vector2 previousPosition = Position;
		    // Base velocity is a combination of horizontal movement control and
		    // acceleration downward due to gravity.
		    velocity.X += movement * MoveAcceleration * elapsed;
		    velocity.Y = MathHelper.Clamp(velocity.Y + GravityAcceleration * elapsed, -MaxFallSpeed, MaxFallSpeed);
		    //velocity.X += movement * 300 * ((float)gameTime.ElapsedGameTime.Milliseconds / 16);
		    velocity.Y = DoJump(velocity.Y, gameTime);
		   
		    // Apply pseudo-drag horizontally.
		    if (IsOnGround)
			    velocity.X *= GroundDragFactor;
		    else
			    velocity.X *= GroundDragFactor;
			    //velocity.X *= AirDragFactor;
		    // Prevent the player from running faster than his top speed.		   
		    velocity.X = MathHelper.Clamp(velocity.X, -MaxMoveSpeed, MaxMoveSpeed);
		    // Apply velocity.
		    Position += velocity *elapsed;
		    Position = new Vector2((float)Math.Round(Position.X), (float)Math.Round(Position.Y));
		    debugVelocityFrameX = position.X - previousPosition.X;
		    debugVelocitySecondXTimer += gameTime.ElapsedGameTime.Milliseconds;
		    if (debugVelocitySecondXTimer >= 1000)
		    {
			    debugVelocitySecondX = debugVelocitySecondXAux;
			    debugVelocitySecondXAux = 0;
			    debugVelocitySecondXTimer = 0;
		    }
		    if (position != previousPosition)
			    if(debugVelocityFrameX >= 0)
				    debugVelocitySecondXAux += (short)debugVelocityFrameX;
			    else
				    debugVelocitySecondXAux += (int)debugVelocityFrameX * -1;
		   
		    // If the player is now colliding with the level, separate them.
		    HandleCollisions(gameTime);
		    // If the collision stopped us from moving, reset the velocity to zero.
		    if (Position.X == previousPosition.X)
			    velocity.X = 0;
		    if (Position.Y == previousPosition.Y)
		    {
			    velocity.Y = 0;
			    jumpTime = 0.0f;
		    }
	    }

tested eg with a PC (PC1) 2.13GHz Intel Core 2 6400 / ATI Radeon HD 4670
and another one: (pc2) 3.00GHz Intel Pentium D / Intel 82945G Express Chipset Family
by displacement difference (moving x axis at supossed (position = velocity * gametime.ElapsedGameTime.TotalSeconds) constant velocity, for example) is 3 seconds in a total of 20 (example: moving pc1 player sprite 6000 pixels in the x-axis at 20 seconds and pc 2 runs the same distance in 17 ).
Tested on a 3rd PC: i72700k / Gigabyte GTX 560 TI
the results are even worse, after some time after starting the game gets like 3 times slower and showing the number of pixels in each frame moved in a debug window in the game (counting updatespersecond with counter variable for updates cuantity and gametime for counting a second show 63fps), it appears as if the number is always constant ( refreshments lose the Update method?).
In this pc if I put the game in fullscreen during the course of the game, the effect of "go slow" is immediate and restore window mode sometimes yield returns to "normal" and sometimes not.
Eventually I began to try a new project to test whether the movement is constant in different pc loading only one sprite and its position value in screen printing.
Occur The same.
I even tried moving a constant amount of pixels explicitly (position + = 5) and different speeds in different pc quantities of pixels moved in x time.
I have the game loop as the default (fixedTimeStep = true ;).
I've also tried turning off and creating another timestep as discussed in different post (eg http://gafferongames.com/game-physics/fix-your-timestep/
but i can´t achieve the desired result, move the same number of pixels in X seconds on different computers with windows.
All pc used for tests use windows 7 enterprise.
Thanks for your help.

#1EusKoder

Posted 07 September 2012 - 04:39 PM

Hello,
I am developing a game using Visual Studio 2010 and XNA 4.0,
after advancing to some extent with the project (a platform based 2d platformer msdn starter kit) I got to test it on different computers with different hardware (CPU, graphics, etc.) and I found that the speed of movement object of the game is quite different, I implemented the PSK physics msdn that are based on time,

		/// <summary>
		/// Updates the player's velocity and position based on input, gravity, etc.
		/// </summary>
		public void ApplyPhysics(GameTime gameTime)
		{
			float elapsed = (float)gameTime.ElapsedGameTime.TotalSeconds;
			Vector2 previousPosition = Position;
			// Base velocity is a combination of horizontal movement control and
			// acceleration downward due to gravity.
			velocity.X += movement * MoveAcceleration * elapsed;
			velocity.Y = MathHelper.Clamp(velocity.Y + GravityAcceleration * elapsed, -MaxFallSpeed, MaxFallSpeed);
			//velocity.X += movement * 300 * ((float)gameTime.ElapsedGameTime.Milliseconds / 16);
			velocity.Y = DoJump(velocity.Y, gameTime);
		  
			// Apply pseudo-drag horizontally.
			if (IsOnGround)
				velocity.X *= GroundDragFactor;
			else
				velocity.X *= GroundDragFactor;
				//velocity.X *= AirDragFactor;
			// Prevent the player from running faster than his top speed.		  
			velocity.X = MathHelper.Clamp(velocity.X, -MaxMoveSpeed, MaxMoveSpeed);
			// Apply velocity.
			Position += velocity *elapsed;
			Position = new Vector2((float)Math.Round(Position.X), (float)Math.Round(Position.Y));
			debugVelocityFrameX = position.X - previousPosition.X;
			debugVelocitySecondXTimer += gameTime.ElapsedGameTime.Milliseconds;
			if (debugVelocitySecondXTimer >= 1000)
			{
				debugVelocitySecondX = debugVelocitySecondXAux;
				debugVelocitySecondXAux = 0;
				debugVelocitySecondXTimer = 0;
			}
			if (position != previousPosition)
				if(debugVelocityFrameX >= 0)
					debugVelocitySecondXAux += (short)debugVelocityFrameX;
				else
					debugVelocitySecondXAux += (int)debugVelocityFrameX * -1;
		  
			// If the player is now colliding with the level, separate them.
			HandleCollisions(gameTime);
			// If the collision stopped us from moving, reset the velocity to zero.
			if (Position.X == previousPosition.X)
				velocity.X = 0;
			if (Position.Y == previousPosition.Y)
			{
				velocity.Y = 0;
				jumpTime = 0.0f;
			}
		}

tested eg with a PC (PC1) 2.13GHz Intel Core 2 6400 / ATI Radeon HD 4670
and another one: (pc2) 3.00GHz Intel Pentium D / Intel 82945G Express Chipset Family
by displacement difference (moving x axis at supossed (position = velocity * gametime.ElapsedGameTime.TotalSeconds) constant velocity, for example) is 3 seconds in a total of 20 (example: moving pc1 player sprite 6000 pixels in the x-axis at 20 seconds and pc 2 runs the same distance in 17 ).
Tested on a 3rd PC: i72700k / Gigabyte GTX 560 TI
the results are even worse, after some time after starting the game gets like 3 times slower and showing the number of pixels in each frame moved in a debug window in the game (counting updatespersecond with counter variable for updates cuantity and gametime for counting a second show 63fps), it appears as if the number is always constant ( refreshments lose the Update method?).
In this pc if I put the game in fullscreen during the course of the game, the effect of "go slow" is immediate and restore window mode sometimes yield returns to "normal" and sometimes not.
Eventually I began to try a new project to test whether the movement is constant in different pc loading only one sprite and its position value in screen printing.
Occur The same.
I even tried moving a constant amount of pixels explicitly (position + = 5) and different speeds in different pc quantities of pixels moved in x time.
I have the game loop as the default (fixedTimeStep = true ;).
I've also tried turning off and creating another timestep as discussed in different post (eg http://gafferongames...-your-timestep/
but i can´t achieve the desired result, move the same number of pixels in X seconds on different computers with windows.
All pc used for tests use windows 7 enterprise pc1 == x86 the others are x64.

The weirdest thing is that I find information about people describing the same problem and that I wear long nights of searches.

Thanks for your help.

PARTNERS