Jump to content

  • Log In with Google      Sign In   
  • Create Account


#Actualownage11

Posted 18 October 2012 - 03:50 PM

never mind,
someone please delete this post,

thank you.

#3ownage11

Posted 16 October 2012 - 11:55 AM

Hello there,

I used to have my custom mouse settings back in the days of Windows 2000.
But seems like Microsoft changed something which make it impossible to work In
Windows XP/7 (Even it's still on the registry),
I'm looking for a good solution for really long time already, without of any success.
And I'm 100% percent sure there's some way to get it back to work !

I hopefully the people in this community (the people who have the most experience you the developers) will turn my light back because that things
pissed me off badly & i'm sure any of you understand how does it's feel to lost the touch
that you liked to play with for years. Posted Image

Alright so this is the main problem...
The funcation :

"MouseThreshold1"
"MouseThreshold2"
Control by the MouseSpeed while it's turn on "2"
You can easily see they are still over the Registry on the default mouse control patch:
[HKEY_CURRENT_USER\Control Panel\Mouse]
But none make it to work like it should be...

Here is a Explanation how does it's supposed to get work like used to be in Windows 2000/XP probably tho (Even I've checked it a while ago):

MouseSpeed,MouseThreshold1 And MouseThreshold2:
These three work together to control how quickly the mouse cursor
moves across the screen as you move the mouse physically

The MouseSpeed parameter can take on values between 0 and 2,
representing the speed of the mouse cursor relative the distance
you've moved the mouse.

The MouseThreshold (1 and 2) properties can take on values between 0 and 12.
At measured time intervals, as you move the mouse, Windows polls the position of
the mouse and the speed at which you're moving it.
if, during one interval, the distance along either the x or y axis is greater than
the first mouse threshold value (MouseThreshold1) and the mouse speed (MouseSpeed)
is not 0, Windows doubles the distance.
if the distance along either the x or y axis is greater than the second mouse
threshold value and the mouse speed is 2, the operating system doubles the distance
that resulted from applying the first threshold test. it is thus possible for the
operating system to multiply relatively specified mouse motion along the x or y axis
by up to four times.

Here is some more of information that I found might help to find the problem:
SPI_GETMOUSE is the first entry in a three-element long array. Entry 0 is set to the user configuration MouseThreshold1 field, entry 1 to MouseThreshold2, and entry 2 to MouseSpeed.

Thanks in advance you are all my last hope.

#2ownage11

Posted 16 October 2012 - 11:34 AM

Hello there,

I used to have my custom mouse settings back in the days of Windows 2000.
But seems like Microsoft changed something which make it impossible to work In
Windows XP/7 (Even it's still on the registry),
I'm looking for a good solution for really long time already, without of any success.
And I'm 100% percent sure there's some way to get it back to work !
I hopefully the people in this community (the people who have the most experience you the developers) will turn my light back because that things
pissed me off badly & i'm sure any of you understand how does it's feel to lost the touch
that you liked to play with for years. Posted Image
Alright so this is the main problem...
The funcation :
"MouseThreshold1"
"MouseThreshold2"
Control by the MouseSpeed while it's turn on "2"
You can easily see they are still over the Registry on the default mouse control patch:
[HKEY_CURRENT_USER\Control Panel\Mouse]
But none make it to work like it should be...
Here is a Explanation how does it's supposed to get work like used to be in Windows 2000/XP probably tho (Even I've checked it a while ago):
MouseSpeed,MouseThreshold1 And MouseThreshold2:
These three work together to control how quickly the mouse cursor
moves across the screen as you move the mouse physically
The MouseSpeed parameter can take on values between 0 and 2,
representing the speed of the mouse cursor relative the distance
you've moved the mouse.
The MouseThreshold (1 and 2) properties can take on values between 0 and 12.
At measured time intervals, as you move the mouse, Windows polls the position of
the mouse and the speed at which you're moving it.
if, during one interval, the distance along either the x or y axis is greater than
the first mouse threshold value (MouseThreshold1) and the mouse speed (MouseSpeed)
is not 0, Windows doubles the distance.
if the distance along either the x or y axis is greater than the second mouse
threshold value and the mouse speed is 2, the operating system doubles the distance
that resulted from applying the first threshold test. it is thus possible for the
operating system to multiply relatively specified mouse motion along the x or y axis
by up to four times.
Here is some more of information that I found might help to find the problem:
SPI_GETMOUSE is the first entry in a three-element long array. Entry 0 is set to the user configuration MouseThreshold1 field, entry 1 to MouseThreshold2, and entry 2 to MouseSpeed.

Thanks in advance you are all my last hope.

#1ownage11

Posted 16 October 2012 - 11:30 AM

Hello there,

I used to have my custom mouse settings back in the days of Windows 2000.
But seems like Microsoft changed something which make it impossible to work In
Windows XP/7 (Even it's still on the registry),
I'm looking for a good solution for really long time already, without of any success.
And I'm 100% percent sure there's some way to get it back to work !
I hopefully the people in this community (the people who have the most experience you the developers) will turn my light back because that things
pissed me off badly & i'm sure any of you understand how does it's feel to lost the touch
that you liked to play with for years. :(
Alright so this is the main problem...
The funcation :
"MouseThreshold1"
"MouseThreshold2"
Control by the MouseSpeed while it's turn on "2"
You can easily see they are still over the Registry on the default mouse control patch:
[HKEY_CURRENT_USER\Control Panel\Mouse]
But none make it to work like it should be...
Here is a Explanation how does it's supposed to get work like used to be in Windows 2000/XP probably tho (Even I've checked it a while ago):
MouseSpeed,MouseThreshold1 And MouseThreshold2:
These three work together to control how quickly the mouse cursor
moves across the screen as you move the mouse physically
The MouseSpeed parameter can take on values between 0 and 2,
representing the speed of the mouse cursor relative the distance
you've moved the mouse.
The MouseThreshold (1 and 2) properties can take on values between 0 and 12.
At measured time intervals, as you move the mouse, Windows polls the position of
the mouse and the speed at which you're moving it.
if, during one interval, the distance along either the x or y axis is greater than
the first mouse threshold value (MouseThreshold1) and the mouse speed (MouseSpeed)
is not 0, Windows doubles the distance.
if the distance along either the x or y axis is greater than the second mouse
threshold value and the mouse speed is 2, the operating system doubles the distance
that resulted from applying the first threshold test. it is thus possible for the
operating system to multiply relatively specified mouse motion along the x or y axis
by up to four times.
Here is some more of information that I found:
SPI_GETMOUSE is the first entry in a three-element long array. Entry 0 is set to the user configuration MouseThreshold1 field, entry 1 to MouseThreshold2, and entry 2 to MouseSpeed.

Thanks in advance you are all my last hope.

PARTNERS