Jump to content

  • Log In with Google      Sign In   
  • Create Account


#ActualKaptein

Posted 07 November 2012 - 07:54 AM

So, you are saying with confidence that I have a bug? I hope so Posted Image

I check for framebuffer completeness, all steps are taken to ensure it works (I wouldn't be getting an image otherwise)
Anyways, yes, the depth-buffer isn't modified if i render to a depth-texture at the same time as i render the scene
And the depth-stuff is working, otherwise my glCopyTexSubImage chain wouldn't work Posted Image

I don't know what to say, or what to write (since i stripped out all the code, i have the perfectionist curse)
But I suppose I will be trying again, since you all seem to agree it will work...
Just to be sure: You are saying that if I bind a FBO and use that FBO to render my entire scene,
take out one of the color targets, bind that texture, continue rendering the scene, and depth-testing will function just as before..
I can remove and add color targets as I please, and the only thing standing in my way is me Posted Image
Please say it's so :)

#1Kaptein

Posted 07 November 2012 - 07:53 AM

So, you are saying with confidence that I have a bug? I hope so :)

I check for framebuffer completeness, all steps are taken to ensure it works (I wouldn't be getting an image otherwise)
Anyways, yes, the depth-buffer isn't modified if i render to a depth-texture at the same time as i render the scene
And the depth-stuff is working, otherwise my glCopyTexSubImage chain wouldn't work :)

I don't know what to say, or what to write (since i stripped out all the code, i have the perfectionist curse)
But I suppose I will be trying again, since you all seem to agree it will work...
Just to be sure: You are saying that if I bind a FBO and use that FBO to render my entire scene,
depth-testing will function just as before, I can remove and add color targets as I please, and the only thing standing in my way is me :P

PARTNERS