Jump to content

  • Log In with Google      Sign In   
  • Create Account


#ActualTzarls

Posted 28 November 2012 - 12:32 PM

I´ve got some errors with the other tests:

The Addon_debugger passed.
The scriptbuilder test reports an "unexpected token "[" at 38,2 and 39,2 and fails. The I get a segmentation fault.

I commented out the scriptbuilder test and scriptMath and serializer tests passed, but then the GC complaint that it couldn´t free an object of type "_builtin_function_" because it was being kept alive by the app.

Then the ScriptHandle and ScriptArray tests passed and I got a segmentation fault.

I tried commenting the first 4 tests (debugger, scriptBuilder, Math and serializer) and I got the GC complaints at the beginning. Then ScriptArray and ScriptHandle passes, the segmentation fault.

Any ideas of where to look for the problem? I´m guessing the asm routines?

EDIT: No, it´s not the asm routines. I commented out only the first test, then the scriptbuilder fails with the "unexpected token" message and then I get the seg fault, with no asm functione being called.

#1Tzarls

Posted 28 November 2012 - 11:55 AM

I´ve got some errors with the other tests:

The Addon_debugger passed.
The scriptbuilder test reports an "unexpected token "[" at 38,2 and 39,2 and fails. The I get a segmentation fault.

I commented out the scriptbuilder test and scriptMath and serializer tests passed, but then the GC complaint that it couldn´t free an object of type "_builtin_function_" because it was being kept alive by the app.

Then the ScriptHandle and ScriptArray tests passed and I got a segmentation fault.

I tried commenting the first 4 tests (debugger, scriptBuilder, Math and serializer) and I got the GC complaints at the beginning. Then ScriptArray and ScriptHandle passes, the segmentation fault.

Any ideas of where to look for the problem? I´m guessing the asm routines?

PARTNERS