Then why don’t you show the code for UpdateSentence()?
Now the application isn't breaking/crashing at this point, it's breaking at another method called "UpdateSentence" which you can see in the screenshot here:
Also, sentence3 is garbage when it is passed to UpdateSentence(). I assume it is a member of the Text class.
Naming conventions such as m_ would go a long way to help people realize from where variables are coming.
It needs to be initialized—this has nothing to do with the functions listed in the topic.