Jump to content

  • Log In with Google      Sign In   
  • Create Account


#ActualGavin Williams

Posted 08 December 2012 - 04:32 AM

Ok I've noticed that you have a lot of live objects, so if you add m_textRenderer.Dispose() to GameWindowTest.Dispose() you'll get rid of 16 of the 17 live objects. But there is still a Surface that needs disposing, and it's probably in m_textRenderer, as it goes away after commenting it out. But I couldn't locate it on a first pass.

As for the main problem :

Test App > Properties > Debug : Enable native code debugging - this gives the full debug output. When I checked this box I got the following problem ...
Signatures between stages are incompatible...

There will be a mismatch somewhere, maybe in inputLayout or in the VertexDeclarations, Or in the shader itself.

#2Gavin Williams

Posted 08 December 2012 - 04:09 AM

Ok I've noticed that you have a lot of live objects, so if you add m_textRenderer.Dispose() to GameWindowTest.Dispose() you'll get rid of 16 of the 17 live objects. But there is still a Surface that needs disposing, and it's probably in m_textRenderer, as it goes away after commenting it out. But I couldn't locate it on a first pass.

As for the main problem :

Test App > Properties > Debug : Enable native code debugging - this gives the full debug output. When I checked this box I got the following problem ...
Signatures between stages are incompatible...

In the shader it looks ok. But there will be a mismatch somewhere, maybe in inputLayout or in the VertexDeclarations. I'm just gonna grab something to eat and a coffee and I'll take a further look at. Post up if you locate where the mismatch is...

#1Gavin Williams

Posted 08 December 2012 - 04:08 AM

Ok I've noticed that you have a lot of live objects, so if you add m_textRenderer.Dispose() to GameWindowTest.Dispose() you'll get rid of 16 of the 17 live objects. But there is still a Surface that needs disposing, and it's probably in m_textRenderer, as it goes away after commenting it out.

As for the main problem :

Test App > Properties > Debug : Enable native code debugging - this gives the full debug output. When I checked this box I got the following problem ...
Signatures between stages are incompatible...

In the shader it looks ok. But there will be a mismatch somewhere, maybe in inputLayout or in the VertexDeclarations. I'm just gonna grab something to eat and a coffee and I'll take a further look at. Post up if you locate where the mismatch is...

PARTNERS