If there's one thing a beginner should be mindful of when writing conditional statements, it is to write comparisons with const value first. "if(true == a)" instead of "if(a == true)" because it prevents accidental assignment.
But when a is bool, "if(a)" is best anyway.
Bull. That notation needs to die a horrible death! It is unnecessary and looks stupid. They mean the same thing, but one reads really weird. You truly gain nothing from that.