Jump to content

  • Log In with Google      Sign In   
  • Create Account


#ActualBaneTrapper

Posted 08 January 2013 - 03:25 PM

Are you compiling with roughly the same parameters/flags?
Are you compiling and running in release mode with both IDE's(compilers)?
Cause debug modes can really slow some things down...
On Visual studio 2010 i got FPS improved up to 80 from 1-11, but on Code::blocks i went from around 700 too around 800.

I downloaded .dll from official sfml site for codeblocks and i get a massive decrease in fps down to 300-330 with release. Also i noticed with site .dll the sound was tearing "stoping for 0.1 - 0.3 each 1 second, if that describes it.

I will try to build my own Visual studio 2010 .dll and i will give you info

EDIT 2::
Also when using Visual studio 2010 i have "Main menu" "Character creation" "Member edit" all these functions are collision and drawing heavy and i get 400-600 fps in visual studio and 400-600 in code::blocks.

EDIT 3::
After building my own .dll files with cmake for visual studio the program fps on debug increased to 130 and release up to 200...

Don't know why... know know how... its acceptable FPS now "Flips the table"

#3BaneTrapper

Posted 08 January 2013 - 01:04 PM

Are you compiling with roughly the same parameters/flags?
Are you compiling and running in release mode with both IDE's(compilers)?
Cause debug modes can really slow some things down...
On Visual studio 2010 i got FPS improved up to 80 from 1-11, but on Code::blocks i went from around 700 too around 800.

I downloaded .dll from official sfml site for codeblocks and i get a massive decrease in fps down to 300-330 with release. Also i noticed with site .dll the sound was tearing "stoping for 0.1 - 0.3 each 1 second, if that describes it.

I will try to build my own Visual studio 2010 .dll and i will give you info

EDIT 2::
Also when using Visual studio 2010 i have "Main menu" "Character creation" "Member edit" all these functions are collision and drawing heavy and i get 400-600 fps in visual studio and 400-600 in code::blocks.

#2BaneTrapper

Posted 08 January 2013 - 01:04 PM

Are you compiling with roughly the same parameters/flags?
Are you compiling and running in release mode with both IDE's(compilers)?
Cause debug modes can really slow some things down...
On Visual studio 2010 i got FPS improved up to 80 from 1-11, but on Code::blocks i went from around 700 too around 800.

I downloaded .dll from official sfml site for codeblocks and i get a massive decrease in fps down to 300-330 with release. Also i noticed with site .dll the sound was tearing "stoping for 0.1 - 0.3 each 1 second, if that describes it.

I will try to build my own Visual studio 2010 .dll and i will give you info

EDIT 2::
Also when using Visual studio 2010 i have "Main menu" "Character creation" "Member edit" all these functions are collision and drawing heavy and i get 400-600 fps in visual studio and 400-600 in code::blocks.

#1BaneTrapper

Posted 08 January 2013 - 12:34 PM

Are you compiling with roughly the same parameters/flags?
Are you compiling and running in release mode with both IDE's(compilers)?
Cause debug modes can really slow some things down...

On Visual studio 2010 i got FPS improved up to 80 from 1-11, but on Code::blocks i went from around 700 too around 800.

 

I downloaded .dll from official sfml site for codeblocks and i get a massive decrease in fps down to 300-330 with release. Also i noticed with site .dll the sound was tearing "stoping for 0.1 - 0.3 each 1 second, if that describes it.

 

I will try to build my own Visual studio 2010 .dll and i will give you info


PARTNERS