Jump to content

  • Log In with Google      Sign In   
  • Create Account


#ActualOrangeatang

Posted 26 April 2013 - 06:21 AM

Hi there!

 

I'm trying to add colour to my 2D light maps, but am having a bit of trouble getting things right.

 

I'm using two render targets, a lighting target and a colour target. I use a stencil buffer with the colour target so I can exclude objects from the lighting effects. After drawing to the colour target, I blend with the lighting target and then draw the final scene to the back buffer.

 

When I render my lights with their colour set to white everything looks great :

 

lLzYVsv.png

 

But when I set the colour of the light to something like green, the light map looks right :

 

OElx0dw.png

 

But the objects themselves aren't draw with any lighting effects, only the ambient lighting colour (which is the clear colour for the lighting buffer)... none of the green tint that  I'm hoping for :

 

oUxyl9e.png

 

After finishing the drawing of my objects to the colour buffer, I use the following to blend with my light map :

 

Effect lightEffect = anEffectManager.GetEffect( myLightMapEffectID );
            
lightEffect.Parameters["ColourMap"].SetValue( myColourTarget );

aSpriteBatch.Begin( SpriteSortMode.Deferred, BlendState.AlphaBlend, null, myRenderLightingState, null, lightEffect );
aSpriteBatch.Draw( myLightingTarget, aDrawRectangle, Color.White );
aSpriteBatch.End();

 

So my shader takes the colour map as a parameter, and tries to blend the lighting target with the current render target (which is the colour map). The render lighting state only draws pixels that have a stencil value of 1, set when I'm drawing all of my objects to the colour buffer.

 

And this is the shader I'm using :

 

// ----------- Global Variables -----------

texture ColourMap;


// --------------- Samplers ---------------

sampler mainSampler : register(s0); // light map texture
sampler colourMapSampler = sampler_state{ Texture = ColourMap; }; // colour buffer


// ---------------- Inputs ----------------

// Pixel shader input
struct PixelShaderInput
{
    float2 myTextureCoords : TEXCOORD0;
};


// --------------- Functions --------------

// Pixel shader 
float4 PixelShaderFunction( PixelShaderInput anInput ) : COLOR0
{
	// Get the colour map and light map colours
	float4 lightMapColour = tex2D(mainSampler, anInput.myTextureCoords);
	float4 colourMap = tex2D(colourMapSampler, anInput.myTextureCoords);
	
    return lightMapColour * colourMap;
}


// ----------------- Passes ---------------

technique Lighting
{
    pass Pass1
    {
        // The pixel shader combines the light map texture, the main scene being rendered and the ambient lighting
        PixelShader = compile ps_2_0 PixelShaderFunction();
    }
}

 

Any ideas what I'm doing wrong here? The colour & lighting render targets are both the same dimensions, so I don't think it's a problem with the texture coordinates (plus it works with the colour set to white). I've tried all of the BlendState possibilities for the light map blending, but nothing really works.

 

Thanks!


#1Orangeatang

Posted 26 April 2013 - 06:17 AM

Hi there!

 

I'm trying to add colour to my 2D light maps, but am having a bit of trouble getting things right.

 

I'm using two render targets, a lighting target and a colour map target. I use a stencil buffer with the colour target so I can exclude objects from the lighting effects. After drawing to the colour target, I blend with the lighting target and then draw the final scene to the back buffer.

 

When I render my lights with their colour set to white everything looks great :

 

lLzYVsv.png

 

When I set the colour of the light to something like green, the light map looks right :

 

OElx0dw.png

 

But the objects themselves aren't draw with any lighting effects, only the ambient lighting colour (which is the clear colour for the lighting buffer)... none of the green mixed with red that I'm hoping for :

 

oUxyl9e.png

 

After finishing the drawing of my objects to the colour buffer, I use the following to blend with my light map :

 

Effect lightEffect = anEffectManager.GetEffect( myLightMapEffectID );
            
lightEffect.Parameters["ColourMap"].SetValue( myColourTarget );

aSpriteBatch.Begin( SpriteSortMode.Deferred, BlendState.AlphaBlend, null, myRenderLightingState, null, lightEffect );
aSpriteBatch.Draw( myLightingTarget, aDrawRectangle, Color.White );
aSpriteBatch.End();

 

So my shader takes the colour map as a parameter, and tries to blend the lighting target with the current render target (which is the colour map).

 

And this is the shader I'm using :

 

// ----------- Global Variables -----------

texture ColourMap;


// --------------- Samplers ---------------

sampler mainSampler : register(s0);
sampler colourMapSampler = sampler_state{ Texture = ColourMap; };


// ---------------- Inputs ----------------

// Pixel shader input
struct PixelShaderInput
{
    float2 myTextureCoords : TEXCOORD0;
};


// --------------- Functions --------------

// Pixel shader 
float4 PixelShaderFunction( PixelShaderInput anInput ) : COLOR0
{
	// Get the colour map and light map colours
	float4 lightMapColour = tex2D(mainSampler, anInput.myTextureCoords);
	float4 colourMap = tex2D(colourMapSampler, anInput.myTextureCoords);
	
    return lightMapColour * colourMap;
}


// ----------------- Passes ---------------

technique Lighting
{
    pass Pass1
    {
        // The pixel shader combines the light map texture, the main scene being rendered and the ambient lighting
        PixelShader = compile ps_2_0 PixelShaderFunction();
    }
}

 

Any ideas what I'm doing wrong here? I've tried all of the BlendState possibilities for the light map blending, but nothing really works.

 

Thanks!


PARTNERS