Jump to content

  • Log In with Google      Sign In   
  • Create Account


#ActualAlessio1989

Posted 05 May 2013 - 11:03 AM

I'm learning the DX11 tutorial of rastertek (http://www.rastertek.com/tutdx11.html).

Since they use the deprecated D3DX APIs family I decided to convert the source code to use DirectXMath and DirectXTK.

 

When I compile the projects with Release configuration everything works fine, but when I switch to Debug configuration they display just a black screen, without any kind of compilation or runtime errors.

 

I'm just a beginner in this world, so I don't have any idea about what could cause this issue.

 

The code is quite the same of the original, with some exception like the maths structures and functions.

 

I attach here the tutorial 4 that I converted. (original source: http://www.rastertek.com/dx11tut04.html).

 

[attachment=15539:DirectX 11 Tutorials VS2012.zip]


#2Alessio1989

Posted 05 May 2013 - 11:02 AM

I'm learning the DX11 tutorial of rastertek (http://www.rastertek.com/tutdx11.html).

Since they use the deprecated D3DX APIs family I decided to convert the source code to use DirectXMath and DirectXTK.

 

When I compile the projects with Release configuration everything works fine, but when I switch to Debug configuration they display just a black screen, without any kind of compilation or runtime errors.

 

I'm just a beginner in this world, so I don't have any idea about what could cause this issue.

 

The code is quite the same of the original, with some exception like the maths structures and functions.

 

I attach here the tutorial 4 that I converted. (original source: http://www.rastertek.com/dx11tut04.html).

 

[attachment=15539:DirectX 11 Tutorials VS2012.zip]


#1Alessio1989

Posted 05 May 2013 - 11:01 AM

I'm learning the DX11 tutorial of rastertek (http://www.rastertek.com/tutdx11.html).

Since they use the deprecated D3DX APIs family I decided to convert the source code to use DirectXMath and DirectXTK.

 

When I compile the projects with Release configuration everything works fine, but when I switch to Debug configuration they display just a black screen, without any kind of compilation or runtime errors.

 

I'm just a beginner in this world, so I don't have any idea about what could cause this issue.

 

The code is quite the same, with some exception like the maths structures and functions.

 

I attach here the tutorial 4 that I converted.

 

[attachment=15539:DirectX 11 Tutorials VS2012.zip]


PARTNERS