Jump to content

  • Log In with Google      Sign In   
  • Create Account

#Actualbonsairobo

Posted 29 July 2013 - 05:40 PM

I can't seem to open an audio device with SDL2_mixer. Calling Mix_OpenAudio(44100, MIX_DEFAULT_FORMAT, 2, 1024) gives the error "no such audio device". I only got one warning when building SDL2_mixer (MP3 support disabled, even though I have smpeg dev libraries). I built from the source in the Hg repo. I'm on Ubuntu 12.04. What's going on?

 

EDIT: I'm dumb. I didn't have libasound2-dev or libpulse-dev when I built the SDL core library. I didn't know SDL2_mixer was dependent on the sound system of SDL. Fixed by recompiling.


#2bonsairobo

Posted 29 July 2013 - 05:40 PM

I can't seem to open an audio device with SDL2_mixer. Calling Mix_OpenAudio(44100, MIX_DEFAULT_FORMAT, 2, 1024) gives the error "no such audio device". I only got one warning when building SDL2_mixer (MP3 support disabled, even though I have smpeg dev libraries). I built from the source in the Hg repo. I'm on Ubuntu 12.04. What's going on?

 

EDIT: I'm dumb. I didn't have libasound2-dev or libpulse-dev when I built the SDL core library. I didn't know SDL2_mixer was dependent on the sound system of SDL. Fixed by recompiling.


#1bonsairobo

Posted 29 July 2013 - 04:23 PM

I can't seem to open an audio device with SDL2_mixer. Calling Mix_OpenAudio(44100, MIX_DEFAULT_FORMAT, 2, 1024) gives the error "no such audio device". I only got one warning when building SDL2_mixer (MP3 support disabled, even though I have smpeg dev libraries). I built from the source in the Hg repo. I'm on Ubuntu 12.04. What's going on?


PARTNERS