Naming is kind of a subjective thing but your naming is fine. At least, it conforms to what's normally expected in a Java project, and your classes are CamelCase, don't use any IWeirdImpl notation, and are descriptive (as far as we can tell - for all we know, your WordGenerator might be your main loop ).
Are you building for J2ME? Anything else and I'd use package names, for convenience and convention.
I am using Java SE(Standard Edition). Thanks for the feedback. It is nice to know the names are great.
Actually the main loop is in the Main.java. The Game loop is in Game.java.
Actually, an instance of WordGenerator class is created inside the Game class because the game needs to generate a new word whether the user got the word right or wrong.
Okay I will try to use packages too.