Jump to content

  • Log In with Google      Sign In   
  • Create Account


- - - - -

Debug problems


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
21 replies to this topic

#21 Andreas Jonsson   Moderators   -  Reputation: 3265

Like
0Likes
Like

Posted 14 September 2004 - 03:49 AM

Thanks for taking the time to write the test case. I'm able to reproduce the problem with your code. I'll find a way to fix the bug soon, I hope.
AngelCode.com - game development and more - Reference DB - game developer references
AngelScript - free scripting library - BMFont - free bitmap font generator - Tower - free puzzle game

Sponsor:

#22 Andreas Jonsson   Moderators   -  Reputation: 3265

Like
0Likes
Like

Posted 14 September 2004 - 04:33 AM

Ok, the problem was actually the assert itself. So you only have to update it (or remove it if you wish). The correct assert is:


assert(from->isConstant || from->dataType.IsPrimitive() || from->dataType.pointerLevel > 0);


(as_compiler.as, line 1810)



AngelCode.com - game development and more - Reference DB - game developer references
AngelScript - free scripting library - BMFont - free bitmap font generator - Tower - free puzzle game




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS