Jump to content

  • Log In with Google      Sign In   
  • Create Account


Vertex Indices


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
No replies to this topic

#1 Anonymous Poster_Anonymous Poster_*   Guests   -  Reputation:

Likes

Posted 25 August 1999 - 10:53 AM

I've been writing my own "animation" engine. Actually all it does is morph between a start mesh and a target mesh. My problem is not with the code actually but with the mesh that I'm using.

I'm using Direct3DRM (I don't think it really matters what I use). But anyways, I created a mesh in 3DStudio, it's a karate guy in one position.
I exported it to 3DS format and then converted it to the .X format for direct3D. Then I used the same mesh in 3DS, changed it a bit, and exported it as a different file name.

The problem is when I try to morph between the meshes, the vertices go all screwy. And that's because the vertex indices go all messed up. Even though I exported the same model in two different positions the vertex indices are messed up.

I even tried to do the morph in 3DS MAX and it goes all screwy.

The vertex at the top of the head mmight be one vertex index, and then on the next mesh the vertex at the top of the head might be another so it becomes messed up and doesn't move properly.

If anyone can help, it would be appreciated.



Sponsor:



Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS