Jump to content

  • Log In with Google      Sign In   
  • Create Account


Need help with loading Wav files using DirectSound


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
2 replies to this topic

#1 jtecin   Members   -  Reputation: 122

Like
Likes
Like

Posted 26 October 1999 - 04:57 PM

I am writing a sound engine, but am new to direct sound. Right now I have it so it should just load wav file and play it.

However, these are the errors I get:

error LNK2001: unresolved external symbol __imp__mmioClose@8

sndDemo.obj : error LNK2001: unresolved external symbol __imp__mmioRead@12

sndDemo.obj : error LNK2001: unresolved external symbol __imp__mmioDescend@16

sndDemo.obj : error LNK2001: unresolved external symbol __imp__mmioAscend@12

sndDemo.obj : error LNK2001: unresolved external symbol __imp__mmioOpenA@12


Any ideas what the problem is?


Sponsor:

#2 Facehat   Members   -  Reputation: 696

Like
Likes
Like

Posted 26 October 1999 - 03:54 PM

You need to link with winmm.lib. Go to the projects menu then settings then click the link tab and add winmm.lib

--TheGoop


#3 Anonymous Poster_Anonymous Poster_*   Guests   -  Reputation:

Likes

Posted 26 October 1999 - 04:57 PM

Thank you very much, it is working now.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS