Jump to content

  • Log In with Google      Sign In   
  • Create Account

D3DIM Managed Textures/Diamond Monster Fusion problem


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
3 replies to this topic

#1 NightShade   Members   -  Reputation: 122

Like
Likes
Like

Posted 02 November 1999 - 11:43 AM

I'm having a problem with textures on a Diamond Monster Fusion card. I'm using automatic texture management. The problem is that non-alpha (either 5,5,5 or 5,6,5, I can't remember which, but I enumerate them and use the one it returns with) textures are not being drawn at all. I load all textures in manually, using the pixelformat structure and a FILE *. The two weird things are that the same code works fine on my Matrox G400, and that textures that have alpha components (either 4,4,4,4 or the one-bit alpha format) DO work on the monster fusion card. I am not getting any error codes, the textures just don't get drawn (or maybe get drawn transparent?)
Has anyone had a similar problem?
Thanks for reading
-ns


Sponsor:

#2 NightShade   Members   -  Reputation: 122

Like
Likes
Like

Posted 02 November 1999 - 05:33 AM

Well I think I just fixed it, kind of. If I do this:
SetRenderState(D3DRENDERSTATE_ALPHABLENDENABLE, false);
SetRenderState(D3DRENDERSTATE_ALPHATESTENABLE, false);
(i.e., turn off alpha blending and alpha transparency) It works on the fusion card. Thats fine and great, but does anybody know why these textures (which had NO alpha pixels) were apparently implicitly having an alpha value of zero?
-ns

#3 Matt   Members   -  Reputation: 122

Like
Likes
Like

Posted 02 November 1999 - 11:02 AM

Since alpha was enabled, it likely had 0 as the default.

Now, you can have texture alpha, which you didn't have, but then also, you can make the triangles themselves transparent. Since alpha was enabled, and you may or may not have used D3DRGBA or D3DRGB, I'd say that you used the later, which may, combined with the alpha state, mean that it renders transparent polygons, with a 0 alpha value, thus, no polygons.

If alpha is enabled, you have to have an alpha texture, and specify the triangles alpha values (Well you don't have to, but it's better overall)


#4 NightShade   Members   -  Reputation: 122

Like
Likes
Like

Posted 02 November 1999 - 11:43 AM

Yeah! Thats exactly it! I forgot to set the alpha value of the color components of the material, making the polygons transparent. Dunno why this worked on the G400, but it works on both now. Thanks for the replies!
-ns

[This message has been edited by NightShade (edited November 02, 1999).]





Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS