Jump to content

  • Log In with Google      Sign In   
  • Create Account


DirectX control panel - debug/retail selection disabled


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
4 replies to this topic

#1 Lysergide   Members   -  Reputation: 684

Like
0Likes
Like

Posted 22 August 2008 - 09:54 AM

Hi guys! I want to switch to DEBUG version of D3D 9, however this selection is disabled under the control panel. what could cause this? it worked earlier this week... Is there any way to solve this? (without having to re-install DirectX SDK) Thanks, Lior Tal.

Sponsor:

#2 sirob   Members   -  Reputation: 1180

Like
0Likes
Like

Posted 22 August 2008 - 10:00 AM

This is usually due to a mismatch between the runtime version and the DX SDK version. If the SDK version is older than the runtime you have installed, it should be disabled in the control panel.

If you recently installed either the DX runtime, or a game that might have updated the DX runtime, this might be the cause.

I'm not aware of any way to undo this, if this is indeed the case, other than getting the most recent SDK version.

Hope this helps.

Sirob Yes.» - status: Work-O-Rama.

#3 Lysergide   Members   -  Reputation: 684

Like
0Likes
Like

Posted 22 August 2008 - 10:02 AM

I had SDK from june 08.

I've installed aug 08 without uninstalling the older one.. perhaps this is what caused the problems ?

i will try a reinstall.

#4 Evil Steve   Members   -  Reputation: 1959

Like
0Likes
Like

Posted 22 August 2008 - 10:11 AM

Quote:
Original post by sirob
I'm not aware of any way to undo this, if this is indeed the case, other than getting the most recent SDK version.
You can sometimes use system restore; I seem to recall that installing a new DirectX runtime sets a system restore point.

Aside from that; download the latest SDK and install it unfortunately.

However, what version of the SDK are you using? I thought the runtime hasn't been updated in years?

#5 Lysergide   Members   -  Reputation: 684

Like
0Likes
Like

Posted 22 August 2008 - 10:13 AM

I've downloaded the august 08 version, its the latest one.

Too late - i'm uninstalling now... we'll see if this will solve the case.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS