Jump to content

  • Log In with Google      Sign In   
  • Create Account

Diamond Viper 770


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
5 replies to this topic

#1 Anonymous Poster_Anonymous Poster_*   Guests   -  Reputation:

Likes

Posted 06 December 1999 - 09:09 AM

I have a Pentium II 200mhz and I just bought a Diamond Viper 770 (TNT2 w/32MB) to replace my aging STB Velocity (Riva 128). I installed the drivers from the CD and reinstalled Quake 2 and tried to play the GL version. It's choppy and slow! What the hell??? To add to that, the tile based engine that I wrote using DirectX gets half the fps it use to. What gives? I was hoping the new video card would boost some fps on either one of those.

Sponsor:

#2 Jeranon   Members   -  Reputation: 122

Like
Likes
Like

Posted 02 December 1999 - 01:59 PM

Pentium 2 200MHz??

#3 Hoff   Members   -  Reputation: 122

Like
Likes
Like

Posted 02 December 1999 - 02:49 PM

Download the latest drivers. If performance was that bad, it probably came with terrible OpenGL drivers. But I don't know what to tell you about the DX performance...maybe that's another driver thing too.

#4 Enigm@   Members   -  Reputation: 122

Like
Likes
Like

Posted 06 December 1999 - 05:56 AM

May be you have to install the latest
ICD OpenGL drivers for your game and /or
your graphics card.

Make sure that there is no trouble with
your installed DirectX drivers.
Try to use DirectX 7.0 and your latest
drivers for your graphics card.


#5 Chappa   Members   -  Reputation: 122

Like
Likes
Like

Posted 06 December 1999 - 07:53 AM

There is a solution!
I had the same problem until a friend of mine told me to download the latest drivers at www.nvidia.com. Should be something named Detonator X.XX (where x stands for the version-number). These drivers are optimized for the TNT2 chipset so you should not encounter any problems. After I installed them, Quake run soft and smoothly. Before, however, it run at aprox. 1 fps. And don't worry that the drivers aren't from Diamond. They're even better... (well, I might be wrong.)

//----//
blah...


#6 JD   Members   -  Reputation: 208

Like
Likes
Like

Posted 06 December 1999 - 09:09 AM

Check if Diamond drivers are Windows Hardware Quality Labs certified i.e.(WHQL), if yes they should let the card buffer only 1.5 frames ahead, not 100's of frames ahead like my Permedia2 from CreativeLabs did. I installed reference drivers(WHQL) from 3DLabs and no problems. Driver people cheat on non-interactive benchmarks by buffering more frames ahead to give them higher fps ratings. I had to insert DDFLIP_DONOTWAIT flag and that caused the immediate return from the flip function so my input keys could be read, otherwise you wait until the card buffers frames before it returns from the flip function, I think Have fun.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS