Jump to content

  • Log In with Google      Sign In   
  • Create Account


Bright lights in OpenGL


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
13 replies to this topic

#1 Ketzal   Members   -  Reputation: 122

Like
Likes
Like

Posted 28 June 2001 - 05:34 PM

Maybe I just haven''t read the docs as I would but, is there a way to have a REALLY BRIGHT light using OpenGL''s lighting facility or the only way to achieve this it to set each vertex color manually? I tried using GL_SPECULAR with (1.0,1.0,1.0,1.0) and GL_DIFUSSE with (1.0,1.0,1.0,1.0), but the brightest color it produces is just the texture''s original colors, just a little brighter, (at first I used only two lights, then three, but the only one that changes is the diffuse color, not the highlight) Can anyone help?

Sponsor:

#2 Obelix   Members   -  Reputation: 122

Like
Likes
Like

Posted 28 June 2001 - 10:51 PM

Your texture will not get much of a highlight with the normal GL specular but the separate specular extension will get the job done. A little demo, information and links from ATI http://www.ati.com/na/pages/resource_centre/dev_rel/sdk/RadeonSDK/Html/Samples/OpenGL/RadeonSeparateSpecular.html

I think that most cards supports this extension.

#3 Krippy2k   Members   -  Reputation: 134

Like
Likes
Like

Posted 29 June 2001 - 08:04 AM

I don''t think the lighting values are clamped. I''m not sure if it is standard, but using 10.0, 10.0, 10.0, 10.0 instead of all 1.0s makes a bright light on a GeForce 2 GTS pro.



#4 zedzeek   Members   -  Reputation: 528

Like
Likes
Like

Posted 29 June 2001 - 10:59 AM

if u use texenv modulate, things will only darken. to brighten use modulate2 or add

http://members.xoom.com/myBollux

#5 Ketzal   Members   -  Reputation: 122

Like
Likes
Like

Posted 29 June 2001 - 01:51 PM

Thanks! I''ll try all of them.

#6 gph-gw   Members   -  Reputation: 122

Like
Likes
Like

Posted 29 June 2001 - 02:04 PM

quote:
Original post by Krippy2k
I don''t think the lighting values are clamped. I''m not sure if it is standard, but using 10.0, 10.0, 10.0, 10.0 instead of all 1.0s makes a bright light on a GeForce 2 GTS pro.




It also does that on my Voodoo. Since it''s not in an extention it might be standard.


#7 zedzeek   Members   -  Reputation: 528

Like
Likes
Like

Posted 29 June 2001 - 11:08 PM

that is normal behaviour the 0-1 clamping happens last

http://members.xoom.com/myBollux

#8 Ketzal   Members   -  Reputation: 122

Like
Likes
Like

Posted 30 June 2001 - 08:27 AM

Nope. Using any values above 1.0, 1.0, 1.0, 1.0 effectively defeats lighting on my TNT2 M64 (textures are presented on its original colors).

#9 zedzeek   Members   -  Reputation: 528

Like
Likes
Like

Posted 30 June 2001 - 10:09 AM

which is as bright as its gonna get with modulate. as i said above try add

http://members.xoom.com/myBollux

#10 Krippy2k   Members   -  Reputation: 134

Like
Likes
Like

Posted 30 June 2001 - 11:20 AM

Hmmm... Well I just noticed that it actually doesn''t get any brighter than the texture color that way. Apparently the reason I was thinkin it was getting brighter was because when I use all 1.0s for an ambient light it is full brightness when I am turned 1 direction, then when I rotate 180 degrees it dims to about half brightness? lol. I didn''t notice before that it changed when I moved that way.

If I set everything to 10.0s it doesn''t change when I move so it is always full brightness. Wierd stuff.

I''m interested now. lol

What do you mean by add or modulate2?

The only texenv functions that I see are GL_MODULATE, GL_BLEND and GL_DECAL ??

There is a GL_ADD but it is regarding the accumulation buffer.

??


THanks
Krippy

#11 Ketzal   Members   -  Reputation: 122

Like
Likes
Like

Posted 30 June 2001 - 01:23 PM

Try passing GL_ADD to gl_TexEnvf. It uses an additive drawing mode to draw the texture. It DOES light things, but you miss ALL shadows!! Guess you can''t have everything (groan)...

#12 Krippy2k   Members   -  Reputation: 134

Like
Likes
Like

Posted 30 June 2001 - 07:30 PM

Ahhh... Does make it brighter... But murders alphablending... lol. Everything I have with any transparency comes out as a white block.
Oh well.

#13 zedzeek   Members   -  Reputation: 528

Like
Likes
Like

Posted 01 July 2001 - 01:38 PM

not bright enuf, now to bright sheesh some ppl
u also might wanna have a look at the tex_env_combine extension it gives a bit more control over ''brightness''

http://members.xoom.com/myBollux

#14 aDasTRa   Members   -  Reputation: 122

Like
Likes
Like

Posted 05 July 2001 - 03:59 PM

i dont know if you guys are already doing this, but you may want to turn off lighting before you do any blending, then turn it back on when done. this may be a redundant comment, but i know i wasn''t doin it at first and it screwed up my rendering. also, you may need to leave all the blending stuff to the end.

<(o)>




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS