Jump to content

  • Log In with Google      Sign In   
  • Create Account

We're offering banner ads on our site from just $5!

1. Details HERE. 2. GDNet+ Subscriptions HERE. 3. Ad upload HERE.


Setting Up OpenGL


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
4 replies to this topic

#1 ThreeRight   Members   -  Reputation: 122

Like
0Likes
Like

Posted 18 March 2009 - 06:12 PM

I suspect that i installed openGL on my computer wrong because I am getting an error about glut.h. I am following this tutorial, http://www.cprogramming.com/tutorial/opengl_projections.html but when i try to compile it. The error i get is LINK : fatal error LNK1104: cannot open file 'glut.h' I have the files in... C:\Program Files\Microsoft Visual Studio 9.0\VC\includeGL.H GLAUX.H glext.h glprocs.c glprocs.h GLU.H glut.h list.txt wglext.h

Sponsor:

#2 Caste   Moderators   -  Reputation: 969

Like
0Likes
Like

Posted 19 March 2009 - 12:51 AM

Try this:
#include <GL/glut.h>

As most of the time the GLUT header is inside the GL folder.

#3 mrbastard   Members   -  Reputation: 1573

Like
0Likes
Like

Posted 19 March 2009 - 12:59 AM

are you sure you installed glut?

#4 ThreeRight   Members   -  Reputation: 122

Like
0Likes
Like

Posted 19 March 2009 - 04:20 PM

GL/glut.h doesn't work and yes i installed it. (i think)

C:\Program Files\Microsoft Visual Studio 9.0\VC\lib\gl
GLAUX.LIB
GLU32.LIB
glut32.lib
OPENGL32.LIB

i copied the DLLs into C:\WINDOWS\system32

I don't quite remember what i did with the def file...


Maybe its the compiler settings... I use Visual C++ 2008 Express Edition.
If it is the compiler settings, how do i set up the compiler/profile to make it work?

#5 Caste   Moderators   -  Reputation: 969

Like
0Likes
Like

Posted 19 March 2009 - 08:32 PM

Well the compiler is looking for the header file glut.h, which should be in one of your include paths (if that C:\Program Files\Microsoft Visual Studio 9.0\VC\includeGL.H meant C:\Program Files\Microsoft Visual Studio 9.0\VC\include with the file GL.H, then this is weird, the GL header usually is in an GL subdir).

If you get rid of that error and your program compiles correctly, then the linker will look for the .lib library.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS