Jump to content

  • Log In with Google      Sign In   
  • Create Account

We're offering banner ads on our site from just $5!

1. Details HERE. 2. GDNet+ Subscriptions HERE. 3. Ad upload HERE.


mixing colors and textures


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
3 replies to this topic

#1 marcthenarc   Members   -  Reputation: 133

Like
0Likes
Like

Posted 22 March 2009 - 06:04 AM

Hello. I've been following Nehe's tutorials and started to mix and match different lessons. One problem I bumped into was mixing color based polygons with texture based ones. I used lesson 5 as a template and rendered the cube with texture mapping instead of color while leaving the pyramid intact. (Quick Reminder, lesson 5 is about a spinning pyramid and cube, both using glColor3f() to color the triangles and quads.) After applying the texture, the pyramid is still colored but dull and the cube's colors where way off. I then read Lesson 17 which mixes both techniques and then I discovered how the color needs to be set to bright white before rendering the texture. My cube renders beautifully now. But Lesson 17 doesn't seem to do anything special for brightening up glColor3f()-based quads. If I comment out the cube rendering, the pyramid is back to bright colors but so I don't think it has anything to do with the initial setup in the initGL() function. I only use glEnable(GL_TEXTURE_2D) and glBindTexture(GL_TEXTURE_2D, texture[0]) before rendering the cube with GL_QUADS and applying texture to it. No lighting tricks, etc. What could make the pyramid so dull when the cube is rendered *after* it ? Any help appreciated.

Sponsor:

#2 lc_overlord   Members   -  Reputation: 436

Like
0Likes
Like

Posted 22 March 2009 - 08:22 AM

Did you apply the correct texture coordinates?

Anyway what you describe is normal when you use both texturing and glColor3f it blends the colors using the formula (texture*color) on each color channel separatly. thus it always gets a bit darker unless you use colors equal or higher than one.

#3 marcthenarc   Members   -  Reputation: 133

Like
0Likes
Like

Posted 22 March 2009 - 10:42 AM

Hello lc_overlord. Thanks for responding.

I guess if you haven't seen NeHe's tutorial or don't have it on hand, my previous post was misleading.

In NeHe's lesson 5, (http://nehe.gamedev.net/data/lessons/lesson.asp?lesson=05), both pyramid and cube are colored only with 3fColor calls. My "contribution" was to texture map the cube to see if I use both 3fColor-ed objects and texture-mapped object in the same scene. But I also wrote that, thanks to lesson 17 (http://nehe.gamedev.net/data/lessons/lesson.asp?lesson=17), I discovered that an extra call to 3fColor before rendering the cube sets the brightness of the texture mapping - which is what you suggested later in the your post.

---

My problem was that the pyramid would be heavily influenced by the cube's texture mapping, even though it has no texture and even if it is rendered before the cube.

And it hit me! If, earlier, the cube's color was off the chart because of the pyramid's last call to 3fColor, I guess the pyramid would be too dark because the cube's mapping is still turned on in some way after each loop. Well, I added glDisable(GL_TEXTURE_2D) after the cube rendering and voilà! Perfect rendering of both objects in full, bright colors.

Part of my error was ripping my texture code from lesson 8 (http://nehe.gamedev.net/data/lessons/lesson.asp?lesson=08). In this lesson, there is only a textured cube. And only one call to glEnable(GL_TEXTURE_2D) in intGL(). There is no call to glDisable(GL_TEXTURE_2D) in any point in code. Why should there be ? It only renders a textured cube.

Funny how lesson 17 doesn't disable texturing in the code either. It probably doesn't need it. But ...

So much text for such a little problem. :) Unless someone finds a problem in switching GL_TEXTURE_2D on and off all the time. Could this cause a performance hit in larger projects ?

Thanks a bunch.

#4 lc_overlord   Members   -  Reputation: 436

Like
0Likes
Like

Posted 22 March 2009 - 11:51 AM

yea it's a common problem, since openGL is a state machine it saves all states until you change them, this leads to confusion for some people as they don't expect the previous rendering pass to affect the current one.

So basically every time you want to do something different you have to assume that all the settings are way of and then reset them for what you currently need.

it's not uncommon for most functions that does something specific starting with something like this

ViewOrtho(100,100); //sets the camera to orthographic projection
glDisable(GL_TEXTURE_GEN_S);
glDisable(GL_TEXTURE_GEN_T);
glEnable(GL_TEXTURE_2D);
glDisable(GL_DEPTH_TEST);
glDisable(GL_LIGHTING);
glDepthMask(GL_FALSE);
glBlendFunc(GL_ONE,GL_ONE);
glEnable(GL_BLEND);
glColor4f(1.0f, 1.0f, 1.0f, 1.0f);
glBindTexture(GL_TEXTURE_2D,hl[i].tex[0]);




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS