Jump to content

  • Log In with Google      Sign In   
  • Create Account


glAlphaFunc


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
1 reply to this topic

#1 WarAmp   Members   -  Reputation: 723

Like
Likes
Like

Posted 29 June 2001 - 08:11 AM

Hey there all, heres a quick question for ya: GL_ALPHA_TEST supported in hardware, or is it strictly a software test? My hardware is a TNT2 Ultra, and whenever I enable Alpha testing, it cuts my framerate down to anywhere between 4-20 fps, depending on how much of the alpha tested poly I can see. Also, when Multitexture is enabled, is the alpha test performed before or after the texture units in the pipeline? I''m using multitexture to combine some alpha values, and I want to test the resulting alpha So far, it doesnt seem to work, and it slows me down incredibly. Any help would be greatly appreciated. Waramp.

Sponsor:

#2 mittens   Moderators   -  Reputation: 1315

Like
Likes
Like

Posted 29 June 2001 - 12:34 PM

I don''t know this for sure, but I am pretty sure that alpha testing is done in hardware. It will still cause some slowdown though, because there are some expensive computations involved... Either that, or your card may not support it.

------------------------------
Trent (ShiningKnight)
E-mail me
OpenGL Game Programming Tutorials




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS