Jump to content

  • Log In with Google      Sign In   
  • Create Account


Pixmap performance problem


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
2 replies to this topic

#1 salmank   Members   -  Reputation: 122

Like
Likes
Like

Posted 01 July 2001 - 08:43 PM

Hi, I''m pretty new to opengl. I''m working on an app which needs to fill a large (900*900 pixel) moving background image with a pixmap at atleast 30 fps... Right now, I''m getting abysmal performance. What''s the fastest way of moving the image from the processor memory to the framebuffer? Simple glDrawPixels() calls don''t seem to give me enough performance. As far as I can see, the memory transfers aren''t large enough to be a problem... any idea where the bottleneck might be? I''d appreciate any help.

Sponsor:

#2 Obelix   Members   -  Reputation: 122

Like
Likes
Like

Posted 02 July 2001 - 10:14 AM

It is slow to transfer from the processor memory to the card. You are supposed to upload your images to the card. Even a blit API like DirectDraw will propably have hard to reach at least 30fps for a 900x900 bitmap.

#3 outRider   Members   -  Reputation: 852

Like
Likes
Like

Posted 05 July 2001 - 12:56 PM

Make your image into texture and throw it in VRAM. 900x900 isn''t the easiest size to deal with but I''d either make a 912x912 texure (textures have to be multiples of 16 so 900 wouldn''t work) or if you wanted a smaller texture size to support old cards then maybe 3 or 4 smaller texures.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS