Jump to content

  • Log In with Google      Sign In   
  • Create Account


Error: Unresolved external '_main'


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
9 replies to this topic

#1 noiser   Members   -  Reputation: 122

Like
Likes
Like

Posted 08 August 2001 - 02:21 AM

Hi ... Newbie here and I registrated today ... Now to my problem ... im currently testing Nehe:s Opengl tutorials and when I tries to compile the cpp code I gets this message: Error: Unresolved external ''_main'' referenced from C:\BC\LIB\C0X32.OBJ Does anyone know why I get it and what I should do to get ride of it ??? (Getting a little mad because I just spent 3 hours trying to make all the lib files and such to work(Which they does now))

Sponsor:

#2 mittens   Moderators   -  Reputation: 1315

Like
Likes
Like

Posted 08 August 2001 - 04:26 AM

You created a console application, you need to create a Win32 application (for the project).

------------------------------
Trent (ShiningKnight)
E-mail me
Shining Darkness- A division of Chromesphere Studios

#3 noiser   Members   -  Reputation: 122

Like
Likes
Like

Posted 08 August 2001 - 07:29 PM

..........!!!!!!!........... LOL !!!
I didnt thought of that ... Thanks .. ! ..

#4 noiser   Members   -  Reputation: 122

Like
Likes
Like

Posted 08 August 2001 - 08:46 PM

hmm ... Yet another newbie question ...

Error: Unresolved external ''auxDIBImageLoadA'' referenced from D:\CPP LÄXA\LESSON19\TEST.OBJ

I get this error when trying to compile the code from lesson 19 ... Got any clue of whats wrong =?=

#5 Beer Hunter   Members   -  Reputation: 712

Like
Likes
Like

Posted 08 August 2001 - 09:04 PM

You need to link glaux.lib to your project. You can do that in the project options.

#6 flame_warrior   Members   -  Reputation: 122

Like
Likes
Like

Posted 08 August 2001 - 09:06 PM

Hi,

You have to link it to glaux.lib.
Go to project->settings->link(I think), read the Nehe-1st chapter.


#7 noiser   Members   -  Reputation: 122

Like
Likes
Like

Posted 08 August 2001 - 10:13 PM

Yea ... But the tutorial only shows how to do it for visual c++ ... And Im using Borland c++ 5.02 ...

Edited by - noiser on August 9, 2001 5:15:45 AM

#8 flame_warrior   Members   -  Reputation: 122

Like
Likes
Like

Posted 09 August 2001 - 08:45 PM

I am only used to borland''s commandline compiling.

The way to do is
1) pragmas - add the following at the start of the code
#pragma comment(lib, "PATH/LIBRARY")
#pragma comment(lib, more libraries)

Path = directory of library.

2) use -LPATH -lLibrary

#9 noiser   Members   -  Reputation: 122

Like
Likes
Like

Posted 09 August 2001 - 09:58 PM

Error: ''C:\BC5\LIB\GL\GLAUX.LIB'' contains invalid OMF record, type 0x21

Error: ''C:\BC5\LIB\GLAUX.LIB'' contains invalid OMF record, type 0x21

It makes no differense which one I choose ...


One problem solved ... Another one appers ...
Any clues ???

(Wants visual c++, But only got Borland)

#10 Beer Hunter   Members   -  Reputation: 712

Like
Likes
Like

Posted 09 August 2001 - 11:13 PM

Your glaux.lib is in coff format, not omf format. Run coff2omf.exe on it, or find a borland-compatible glaux.lib on the internet.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS