Jump to content

  • Log In with Google      Sign In   
  • Create Account


OpenGL and mingw


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
4 replies to this topic

#1 Timbo000   Members   -  Reputation: 122

Like
Likes
Like

Posted 27 August 2001 - 05:05 AM

I''m fairly new to openGL and even newer to programming on for windows. I''ve done a little openGL programing in linux and I wanted to try and learn more openGL but I wanted to do it in windows. I''ve been trying to get openGL & glut to work with mingw but I keep getting glut32.lib No such file or directory. I''m using mingw version 2.95.2 for msvcrt.dll from Mumit Khan. I''m using the the files from www.opengl.org for win32 and glut version 3.7 Can anyone help me?

Sponsor:

#2 Null and Void   Moderators   -  Reputation: 1087

Like
Likes
Like

Posted 27 August 2001 - 09:30 AM

I don''t think MinGW uses the MSVC-style .lib files. It comes with OpenGL (just use -lGL and -lGLU as you do with gcc), and I don''t know about GLUT (I''m sure there''s some GLUT libraries floating around in the format it understands if it doesn''t come with them). If I''m mistaken correct me .

[Resist Windows XP''s Invasive Production Activation Technology!]

#3 Timbo000   Members   -  Reputation: 122

Like
Likes
Like

Posted 27 August 2001 - 11:24 AM

What does it use and is there any way to convert the .lib files to what mingw uses?

#4 Null and Void   Moderators   -  Reputation: 1087

Like
Likes
Like

Posted 27 August 2001 - 11:38 AM

Well, it looks like it uses a ported version of GCC''s static library format. You may be able to find a MinGW32 GLUT ".a" around somewhere. If you don''t, you can always build yourself one from the source. I don''t think there''s a utility to convert Microsoft''s .lib format to .a though...

[Resist Windows XP''s Invasive Production Activation Technology!]

#5 Timbo000   Members   -  Reputation: 122

Like
Likes
Like

Posted 27 August 2001 - 11:42 AM

I got it working, thanks for your help.
I did get it to work with the .lib files?
It appears that mingw just didn't like the version of glut I was using. I tryed version 3.6 and my code compiled without a hitch.
I appreciate your input.

compiled using gcc cube.c -lopenGL32 -lglu32 -lglut32 -o cube


Edited by - Timbo000 on August 27, 2001 6:44:48 PM




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS