Jump to content

  • Log In with Google      Sign In   
  • Create Account


NeHe Prod Lesson6


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
1 reply to this topic

#1 sudheer   Members   -  Reputation: 100

Like
0Likes
Like

Posted 21 March 2011 - 12:25 AM

Dear Sir,

I am a beginner in the openGL. I am learning through NeHe openGL productions. I have copied the code of lesson 6
to the Microsoft Visual Studio. After Building the program i am getting the following error:

1>------ Build started: Project: myprj6, Configuration: Debug Win32 ------
1>Compiling...
1>lesson6.cpp
1>c:\documents and settings\student\my documents\visual studio 2008\projects\myprj6\myprj6\lesson6.cpp(41) : warning C4996: 'fopen': This function or variable may be unsafe. Consider using fopen_s instead. To disable deprecation, use _CRT_SECURE_NO_WARNINGS. See online help for details.
1> c:\program files\microsoft visual studio 9.0\vc\include\stdio.h(237) : see declaration of 'fopen'
1>Linking...
1>lesson6.obj : error LNK2019: unresolved external symbol _auxDIBImageLoadA@4 referenced in function "struct _AUX_RGBImageRec * __cdecl LoadBMP(char *)" (?LoadBMP@@YAPAU_AUX_RGBImageRec@@PAD@Z)
1>C:\Documents and Settings\student\My Documents\Visual Studio 2008\Projects\myprj6\Debug\myprj6.exe : fatal error LNK1120: 1 unresolved externals
1>Build log was saved at "file://c:\Documents and Settings\student\My Documents\Visual Studio 2008\Projects\myprj6\myprj6\Debug\BuildLog.htm"
1>myprj6 - 2 error(s), 1 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

I also would like to know where i should copy the Data (Which contains the BMP image) folder given in the lesson6. I tried by copying the folder in C:\Documents and Settings\student\My Documents\Visual Studio 2008\Projects\myprj6. But could not succeed. Could you please clarify my doubt.

Thanking you
Sudhir

Sponsor:

#2 lc_overlord   Members   -  Reputation: 435

Like
0Likes
Like

Posted 21 March 2011 - 03:55 AM

For your first question you can check out the link in my signature below.

Regarding the data folder, if you run it from visual studio then i think the folder location is correct, otherwise it should be in whatever folder the .exe ends up in, well at least that's the default behaviour, your setup could be different so check around a little.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS