Jump to content

  • Log In with Google      Sign In   
  • Create Account

Different results when viewing on laptop vs desktop (w/ detials)


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
1 reply to this topic

#1 chbfiv   Members   -  Reputation: 139

Like
0Likes
Like

Posted 21 April 2011 - 12:42 PM

We are using XNA (custom rendering solution, not the one provided by default w/ XNA).

Both computers are Windows 7, w/ DirectX 9.0c, Shader 3.0
Desktop is x64 and Nvidia Geforce GTX 570
Laptop is x32 and Nvidia Quadro FX 1800M

The main problem is that we export our models w/ channel 2 AO passes; they arn't showing up on the laptop but they are (and have been) on the desktop. After talking with the team who developed the render engine they seem to think it's something in the shader that isn't supported by the laptop. From what they explained, the blending for channel 2 was happening at the shader level, not using TextureBlendStages at the api level.

The first thing I looked into was the MaxTextureBlendStages and MaxSimultaneousTextures in the DXSDK Caps viewer and I found that both the desktop and the laptop have the same setting of 8 for both. W/ that I'm out of obvious options as to understand why the shader wouldnt blend the same on both adapters at the shader level w/ the same shader version.

Also, a second more minor issue we found was that the laptop was exaggerating the specularity significantly more than on the desktop. It was easy enough to dial down for our purposes.
-BourkeIV

Sponsor:

#2 chbfiv   Members   -  Reputation: 139

Like
0Likes
Like

Posted 23 April 2011 - 07:33 AM

Strangely enough I figured out that the spec was canceling the shadowmap completely. I'm not sure why the laptop and desktop process the spec pass w/ different results, but my main issue was resolved.
-BourkeIV




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS