Jump to content

  • Log In with Google      Sign In   
  • Create Account


Linking errors, help the newbie!


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
4 replies to this topic

#1 Anton LaVey   Members   -  Reputation: 122

Posted 05 January 2000 - 09:02 AM

I get the following error when I compile a simple project. I am using MSVC++6 and things are not going well for me, becayse I can''t even compile... This is really getting me down because I can''t make games!--------------------Configuration: DXExample - Win32 Debug-------------------- Linking... LIBCD.lib(wincrt0.obj) : error LNK2001: unresolved external symbol _WinMain@16 Debug/DXExample.exe : fatal error LNK1120: 1 unresolved externals Error executing link.exe. DXExample.exe - 2 error(s), 0 warning(s) Thanks for any help that anyone can provide... I have set everything up as I was instructed but I am obviously missing a .lib file (I think). Anton LaVey

Sponsor:

#2 C++ Freak   Members   -  Reputation: 122

Posted 05 January 2000 - 11:40 AM

did you include window.h and windowsx.h?




C++ Rocks

#3 vallis   Members   -  Reputation: 122

Posted 05 January 2000 - 03:05 PM

Have you got a WinMain? And if so make sure the prototype is exectly the following:

int WINAPI WinMain(HINSTANCE hInstance, HINSTANCE hPrevInstance, LPSTR lpszCmdLine, int nCmdShow)

If that dosn''t work - mail me your code and I''ll help you.

Good luck.

#4 PoesRaven   Members   -  Reputation: 122

Posted 07 January 2000 - 12:09 PM

make sure if you are using namespaces, to put main in the global namespace
other than that, the other 2 said it all

#5 Anonymous Poster_Anonymous Poster_*   Guests   -  Reputation:

Posted 09 January 2000 - 06:07 PM

I had the same problem with links. I bought the DirectX book from Microsoft..and it says,"Under Options clikc on directory. Add the lib directory to the directory tab and make sure you set it to first priority by clicking the arrow to put it ahead of all the other directories."

After doing that it works fine with no errors. I can compile and everything.

hiryu3@hotmail.com




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS