Jump to content

  • Log In with Google      Sign In   
  • Create Account

Compiling?


Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.


  • You cannot reply to this topic
4 replies to this topic

#1   Members   

122
Like
Likes
Like

Posted 01 October 2001 - 09:47 AM

Whenever I try to compile any file with gl.h included I get errors in the gl.h file. Im using MSVC++98. Sorry if this seems too vague but I don''t think gl.h should be doing this. Anyone else get errors?

#2   Members   

1087
Like
Likes
Like

Posted 01 October 2001 - 09:50 AM

Are you linking the libraries?

[Resist Windows XP''s Invasive Production Activation Technology!]

#3   Members   

122
Like
Likes
Like

Posted 01 October 2001 - 10:02 AM

It could be a few things. Either you're not linking with the correct libraries, or, if you're using win32, try including windows.h before you include gl.h. gl.h requires APIENTRY and WINGDIAPI to be defined (which is done in windows.h).

Edited by - davidko on October 1, 2001 5:03:54 PM

#4   Members   

122
Like
Likes
Like

Posted 01 October 2001 - 10:22 AM

ok linking the libs got rid of some of the errors. but when i try to link i get an unresolved ext symbol WinMain. do all ogl programs need a winmain start point as opposed to a main start point? thanks

#5   Members   

1087
Like
Likes
Like

Posted 01 October 2001 - 10:30 AM

No. But all Win32 programs do (normally).

[Resist Windows XP''s Invasive Production Activation Technology!]




Old topic!

Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.