Jump to content

  • Log In with Google      Sign In   
  • Create Account


DirectX Problems


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
2 replies to this topic

#1 sgdimitris   Members   -  Reputation: 100

Like
0Likes
Like

Posted 29 February 2012 - 11:08 AM

Hello my name is Dimitris Sgourdos and I really need a help!
I use Visual Studio 2010 and I tried to compile the example "Drawing an triangle" in http://www.directxtu.../BA5.aspx#still and I got the following errors:

1> All outputs are up-to-date.
1>TestDirectX.obj : error LNK2019: unresolved external symbol _memset referenced in function _WinMain@16
1>TestDirectX.obj : error LNK2019: unresolved external symbol @_RTC_CheckStackVars@8 referenced in function _WinMain@16
1>TestDirectX.obj : error LNK2019: unresolved external symbol __RTC_CheckEsp referenced in function _WinMain@16
1>TestDirectX.obj : error LNK2001: unresolved external symbol __RTC_Shutdown
1>TestDirectX.obj : error LNK2001: unresolved external symbol __RTC_InitBase
1>TestDirectX.obj : error LNK2001: unresolved external symbol __fltused
1>TestDirectX.obj : error LNK2019: unresolved external symbol _memcpy referenced in function "void __cdecl init_graphics(void)" (?init_graphics@@YAXXZ)
1>TestDirectX.obj : error LNK2019: unresolved external symbol ___security_cookie referenced in function "void __cdecl init_graphics(void)" (?init_graphics@@YAXXZ)
1>TestDirectX.obj : error LNK2019: unresolved external symbol @__security_check_cookie@4 referenced in function "void __cdecl init_graphics(void)" (?init_graphics@@YAXXZ)
1>LINK : error LNK2001: unresolved external symbol _mainCRTStartup
1>c:\users\user\documents\
visual studio 2010\Projects\TestDirectX\Debug\TestDirectX.exe : fatal error LNK1120: 10 unresolved externals
1>
1>Build FAILED.
1>
1>Time Elapsed 00:00:00.15
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Do I miss something? Or do I have to add something? Before these errors I have the following error
1>MSVCRTD.lib(crtexe.obj) : error LNK2019: unresolved external symbol _main referenced in function ___tmainCRTStartup
1>c:\users\user\documents\visual studio 2010\Projects\TestDirectX\Debug\TestDirectX.exe : fatal error LNK1120: 1 unresolved externals
But I added the option "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\lib\amd64" in Additional Library Directories and after I got the errors I mentioned to you at the start.

I would appreciate if you answer to me cause I really need to use DirectX in my project for my university and I have very short deadline. I need to show points in a cartesian system and
it seems so difficult now to me.

Sponsor:

#2 iedoc   Members   -  Reputation: 661

Like
1Likes
Like

Posted 29 February 2012 - 09:56 PM

have you included the directx library directory? go to project, <project name> properties. on the left side, under "configuration properties", click on VC++ directories. then on the right, where it says library directories, click on it, then edit, then click the folder icon at the top of the window that pops up to add a new directory, and add this directory:
C:\Program Files (x86)\Microsoft DirectX SDK (version)\Lib\x86

I'm on a 64 bit windows, but my programs will not run if i link to the x64 libraries, only if i link to the x86, maybe your having this problem too if you linked to the 64 bit libraries (and if you did, unlink to them by deleting the line that links to the 64 bit libraries, then add a line that links to the x84 instead)
Braynzar Soft - DirectX Lessons & Game Programming Resources!

#3 sgdimitris   Members   -  Reputation: 100

Like
0Likes
Like

Posted 01 March 2012 - 07:13 AM

Thank you for your reply!
It seems that I had missed that basic step, that is similar with what you advised me
http://www.directxtutorial.com/TutorialArticles/4-DXWith2010.aspx
Your answer also help me to understand that I didn't installed the latest directX cause I missed some header files and I didn't have
C:\Program Files (x86)\Microsoft DirectX SDK......................
folder.
Anyway, thank you so much for your help! Now, it works!!!!! :-) :-)




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS