Jump to content

  • Log In with Google      Sign In   
  • Create Account

OpenGL Libraries


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
2 replies to this topic

#1 Captacha   Members   -  Reputation: 141

Like
0Likes
Like

Posted 29 March 2012 - 05:25 PM

I'm running Ubuntu 11.10 and I've downloaded an OpenGL library from here, but I think it only comes with the header files. I'm looking for some Linux OpenGL libraries. Can you help me find them?

Sponsor:

#2 SimonForsman   Crossbones+   -  Reputation: 6111

Like
0Likes
Like

Posted 29 March 2012 - 10:02 PM

You want the dev libraries (atleast i assume those are the ones you want as we're on a game dev board):

http://packages.ubun...libgl1-mesa-dev

If you're running ubuntu or debian you should use the package manager instead, or do sudo apt-get install libgl1-mesa-dev from the commandline. (downloading stuff using the browser is quite an odd way to do things in Linux, by using the package manager you get the appropriate version for your OS without hassle)
I don't suffer from insanity, I'm enjoying every minute of it.
The voices in my head may not be real, but they have some good ideas!

#3 swiftcoder   Senior Moderators   -  Reputation: 9997

Like
0Likes
Like

Posted 29 March 2012 - 10:32 PM

(downloading stuff using the browser is quite an odd way to do things in Linux, by using the package manager you get the appropriate version for your OS without hassle)

QFT.

Always look for a given piece of software in the package manager, before you look elsewhere. Not only is the installation process much simplified, but the version in the package manager often has lots of distro-specific tweaks.

For example, the OpenGL libraries from your package manager are typically the only way to obtain a hardware-accelerated OpenGL.

Tristam MacDonald - Software Engineer @Amazon - [swiftcoding]





Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS