Jump to content

  • Log In with Google      Sign In   
  • Create Account

Interested in a FREE copy of HTML5 game maker Construct 2?

We'll be giving away three Personal Edition licences in next Tuesday's GDNet Direct email newsletter!

Sign up from the right-hand sidebar on our homepage and read Tuesday's newsletter for details!


We're also offering banner ads on our site from just $5! 1. Details HERE. 2. GDNet+ Subscriptions HERE. 3. Ad upload HERE.


Do subsequent cbuffer fills affect previous draw calls?!


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
1 reply to this topic

#1 relaxok   Members   -  Reputation: 133

Like
0Likes
Like

Posted 30 March 2012 - 02:45 AM

Hello!

I have a situation where when I am debugging with PIX:

-- i am drawing 4 meshes, each with different cbuffer values that i'm mapping inbetween

-- when i only draw the first mesh, it looks correct and the values in the cbuffer in PIX look right

-- when i enable drawing all 4 meshes in the loop, and go to that FIRST mesh's draw call, the cbuffer values are wrong as if they are getting values from cbuffer fills that happen AFTER that first draw call in time

how is this possible? Do I have to do anything during rendering or initialization to keep this from happening?

Thanks

Sponsor:

#2 Nik02   Crossbones+   -  Reputation: 2875

Like
0Likes
Like

Posted 30 March 2012 - 04:21 AM

This is probably a PIX bug.

Niko Suni





Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS