Jump to content

  • Log In with Google      Sign In   
  • Create Account

[SOLVED]Problems with Vertex- and Indexbuffer


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
1 reply to this topic

#1 Wartime   Members   -  Reputation: 103

Like
0Likes
Like

Posted 05 May 2012 - 07:30 AM

Hi there,

As some of you know, we are programming an MineCraft-like game.
This works very well.

We are allowed to flyring around, selecting blocks, etc....

Now we have a real problem. We want to add a block if somebody clicks the left mousebutton.
But if we add a block we have a graphic problem.

The world is divided in chunks (16*16*16 blocks).
If we add a block or sometimes if we are flying around some chunks are going to dissapear.
We don't know why and so we want to ask you if you can help us.

I've added the complete sourcecode.

Feel free to use it for your own projects if you want.

Attached File  Kubos.rar   840.92KB   40 downloads

--------------------------------------------------------------------------------------------

Problem solved.
In Class "Chunks"->prepare we forgot to reset the variable "index" to "0";

Sponsor:

#2 Wartime   Members   -  Reputation: 103

Like
0Likes
Like

Posted 12 August 2012 - 07:39 AM

I've forgot to upload the final source-code.
We have got an 1.0 (excellent) for our Project.

Thanks to all who helped us.

Here is the final sourcecode.
Feel free to use it for your own projects.

Attached Files






Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS