Jump to content

  • Log In with Google      Sign In   
  • Create Account


gDebugger with C# and OpenTK


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
3 replies to this topic

#1 Lunatix   Members   -  Reputation: 143

Like
0Likes
Like

Posted 08 May 2012 - 07:40 AM

Hi!

I have some trouble with gDebugger and my application - my application is written with C#, windows forms and OpenTK.
Now, if i start my application with gDebugger, everything is fine - except, gDebugger can't break the application or monitor things like framerate, cpu usage etc.
A few months ago, i remember that i started a c++ application without these troubles, everything worked fine!


My System:

NVidia GeForce GT545M
Intel Core i7-2630QM
4 Gb of Ram
Windows 7 x64 (Up to date)

gDebugger from http://gremedy.com (Up to date, 5.8)
Visual Studio 2011
You like voxels? Then you may like... http://gameworx.org/?p=36

Sponsor:

#2 foxfire92   Members   -  Reputation: 111

Like
0Likes
Like

Posted 08 May 2012 - 08:33 AM

AMD distributes gDEBugger now, they have a more up to date version. You might want to try it. http://developer.amd.com/tools/gdebugger/Pages/default.aspx

#3 Lunatix   Members   -  Reputation: 143

Like
0Likes
Like

Posted 08 May 2012 - 08:58 AM

Yep. I know... and what have they done? They removed NVidia GPU support.... when you start your app, it says "You don't have an AMD GPU installed. GPU Debugging will be disabled"...

I hate them for this... >_<
You like voxels? Then you may like... http://gameworx.org/?p=36

#4 Lunatix   Members   -  Reputation: 143

Like
0Likes
Like

Posted 10 May 2012 - 02:34 AM

After searching tons of webpages, i found the solution in google's cache, from support.gremedy.com (Down due an database error).

"in c:\Program Files\Graphic Remedy\gDebugger you'll find two folders: \spies and \spies64.

Copy the Opengl32.dll file from theses folders to the same folder as the application you want to debug (use the one in \spies for 32-bit apps, and the one in \spies64 for 64-bit apps)."

Now, it works very good Posted Image

[Edit] Found out that only "Kernel Debugging" disabled, when using AMD gDebugger...[/Edit]

Edited by Lunatix, 10 May 2012 - 04:21 AM.

You like voxels? Then you may like... http://gameworx.org/?p=36




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS