Jump to content

  • Log In with Google      Sign In   
  • Create Account

FREE SOFTWARE GIVEAWAY

We have 4 x Pro Licences (valued at $59 each) for 2d modular animation software Spriter to give away in this Thursday's GDNet Direct email newsletter.


Read more in this forum topic or make sure you're signed up (from the right-hand sidebar on the homepage) and read Thursday's newsletter to get in the running!


Problem with Textures


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
No replies to this topic

#1 Kuam   Members   -  Reputation: 117

Like
0Likes
Like

Posted 16 June 2012 - 02:31 PM

I'm having trouble drawing images in my program. It is not a variable problem or syntax problem so I'm a little lost.

To clarify, this is in XNA.

I've added the image I want to use to the content (lets just call it Pic), have labeled Texture2D, and have tried to implement the image into my program with the following code:

[source lang="csharp"]myTexture = Content.Load<Texture2D> ("Pic");[/source]

I have also tried this.Content.Load<>

In either case, when I compile the program it tells me that file "Pic" cannot be found. Not sure what I'm missing. I've followed a couple tutorials to a T and no matter which way I've done it, or that I've tried adding different picture files to Content, it cannot "find" the image.

Any help is appreciated.

EDIT: I wiped the file I was working with and tried with a fresh file, only inserting the applicable code. It worked...idk why it couldn't find my file before

Edited by Kuam, 16 June 2012 - 03:26 PM.


Sponsor:



Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS