Jump to content

  • Log In with Google      Sign In   
  • Create Account


Water shader issue


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
9 replies to this topic

#1 riuthamus   Moderators   -  Reputation: 5325

Like
0Likes
Like

Posted 29 June 2012 - 11:22 PM

Posted Image

As you can see from the picture above, we are getting an odd error with the water. Any clue as to what could be causing this?

Sponsor:

#2 ankhd   Members   -  Reputation: 1243

Like
1Likes
Like

Posted 30 June 2012 - 01:42 AM

looks like the order of rendering. To me it looks like your blending the water with the other mesh. try terrain water then objects

#3 riuthamus   Moderators   -  Reputation: 5325

Like
0Likes
Like

Posted 30 June 2012 - 01:52 AM

Thanks, we will try that out and let you know how it goes.

#4 riuthamus   Moderators   -  Reputation: 5325

Like
0Likes
Like

Posted 30 June 2012 - 02:53 AM

Hm... rendering order doesnt seem to be the issue. Reflection/Refraction maps might be the possible cause. Not sure how to figure out what is the cause... to say the least very frustrating. The sad part is, even some high end games like Dead Island have this issue.

#5 TiagoCosta   Crossbones+   -  Reputation: 2080

Like
0Likes
Like

Posted 30 June 2012 - 03:07 AM

Have you tried to debug those pixels in PIX or Nsight?

Could it be caused by the aliasing? Try to implement FXAA or turn on MSAA...

Edited by TiagoCosta, 30 June 2012 - 03:09 AM.


#6 riuthamus   Moderators   -  Reputation: 5325

Like
0Likes
Like

Posted 30 June 2012 - 03:10 AM

Have you tried to debug those pixels in PIX or Nsight?

Could it be caused by the aliasing? Try to implement FXAA or turn on MSAA...


That could work.... but we are having issues adding in FXAA... so many variables. We will try out some AA next and see what happens. Again, thank you for the ideas... any leads are good leads at this point.

#7 Telanor   Members   -  Reputation: 1320

Like
1Likes
Like

Posted 30 June 2012 - 03:40 AM

The reason for it is because the water shader is sampling a part of the reflection map that contains the sky as a result of the perterbation being applied. The pixel would have sampled a part of the terrain before the perterbation. I don't know how to fix this though.

Water:
water.png

Reflection Map:
reflection.png

#8 riuthamus   Moderators   -  Reputation: 5325

Like
0Likes
Like

Posted 30 June 2012 - 04:53 AM

So, i modified our normal map to use the Y axis and it resolved the issue to some degree. Instead of having the atmosphere bleed we are getting block bleed now!

Fixed the atmosphere bleed:
Posted Image

New bleed tile issue:
Posted Image

#9 riuthamus   Moderators   -  Reputation: 5325

Like
0Likes
Like

Posted 18 July 2012 - 06:32 PM

So we ironed out most of the issues, but we are getting this odd issue where the sky is being reflected. Any idea on how we can fix these blue spots?

Posted Image
Posted Image
Posted Image

#10 riuthamus   Moderators   -  Reputation: 5325

Like
0Likes
Like

Posted 21 July 2012 - 08:47 PM

We played with the normal images today and still are having the same issue. I am curious if this is related to how we are creating the shader or if this is a texture based issue. Any advice or idea would be greatly appreciated since we are at a loss. Thanks in advance.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS