Jump to content

  • Log In with Google      Sign In   
  • Create Account

Setting up Collada DOM 2.4.0 in VS 2010


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
2 replies to this topic

#1 TheGoozah   Members   -  Reputation: 118

Like
0Likes
Like

Posted 20 July 2012 - 08:05 AM

Hi!

Ok, this is a strang question for me because I've never had problems setting up an API. Well a first time for everything I guess...
I want to write my own daeParser using the Collada DOM...

But I'm confused how to set it up.... I downloaded the collada-dom-2.4.0.tgz file and unrarred it (link: http://sourceforge.n...lada-dom/files/). I also downloaded the documentation and took a look at the wiki page...

The documentation only says to do the following thing:

• To the “Additional include directories” field, add:
<COLLADA_DOM-path>\include
<COLLADA_DOM-path>\include\1.4

• Under the “General” tab in the “Additional library directories” field, add:
<COLLADA_DOM-path>\lib\1.4
<COLLADA_DOM-path>\external-libs\libxml2\win32\lib

• Under the “Input” tab in the “Additional dependencies” field, add:
libcollada_dae.lib
libcollada_dom.lib
libcollada_STLDatabase.lib
libcollada_LIBXMLPlugin.lib
libxml2_a.lib
iconv_a.lib
zlib.lib



But the \lib folder doesn't exist... Then I read the wiki and it says (http://collada.org/m...isual_Studio.29):


Building the DOM
Project and solution files for Visual Studio are in
<dom-path>\projects


When I try to build the project (vc10-1.4 or vc10-1.5) I get an error (for each file): Unknown compiler version - please run the configure tests and report the results

So basically, I don't know what to do now? How can I get the necessary lib files? Do I need to build them myself and how? Am I missing something? I really need a solution because I need to be able to parse .dae files so I can use them with DirectX and PhysX!

Thanks in advance!!

Sponsor:

#2 TheGoozah   Members   -  Reputation: 118

Like
0Likes
Like

Posted 20 July 2012 - 06:21 PM

Oke I've got rid of the "Unknown compiler version" by adding BOOST 1.50 to the project (still was using BOOST 1.47)
But I still can't build successful libs... I get some other warnings new. (ps: trying to build the dom project (vc10-1.4) in Visual Studio 2010 in Debug mode
In detail:
Spoiler


Please, can someone tell me what these are? Only getting .obj files right now.... Thx in advance!

Edited by TheGoozah, 20 July 2012 - 06:22 PM.


#3 TheOrestes   Members   -  Reputation: 270

Like
2Likes
Like

Posted 01 December 2012 - 11:40 AM

Hi TheGoozah,

I got the Collada-Dom 2.4.0 compiled using both vs2008 & vs2010. Its not as straight as it sounds though.

*Static Lib Steps :
1. Get rid of domAny.h & domAny.cpp file from the project. ( Simply exclude )
2. In project properties, "Additional Include Directories", use "..\..\external-libs\minizip-1.1" instead of "..\..\external-libs\minizip\include" directory.
3. Project Properties>>C/C++>>Language, set "Disable Language Extension" to "NO" ( please google for the explanation )
4. Project Properties>>Librarian>>General>>Additional Library Directories" to ..\..\external-libs\libxml2\win32\lib , ..\..\external-libs\zlib-1.2.5 , ..\..\external-libs\minizip\win32\lib, is empty. it was empty in my case.
5. Last but most important, you should get compilation error saying missing or cannot find "unistd.h" file. Simpy head to "libxml2\include\zconf.h" & replace "unistd.h" by "io.h" ( Please refer to Google for explanation )

These steps got me the static lib for Collada Dom, strange to see that default download has these issues ( unless I did something terribly wrong )
Nevertheless, you should have debug & release versionof static lib available once you build the project. As per the DLL, you need to make sure that there exists minizip1.1 lib in project properties, by default its for minizip default version. Compiling the minizip1.1 will give you the required lib.

Hopefully this will solve your issue just like me.

Cheers.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS