Jump to content

  • Log In with Google      Sign In   
  • Create Account

We're offering banner ads on our site from just $5!

1. Details HERE. 2. GDNet+ Subscriptions HERE. 3. Ad upload HERE.


Don't forget to read Tuesday's email newsletter for your chance to win a free copy of Construct 2!


DXUT V-Sync Multithread Issue


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
No replies to this topic

#1 thekiwimaddog   Members   -  Reputation: 155

Like
0Likes
Like

Posted 19 September 2012 - 11:17 AM

Hi everyone!

I'm using DXUT as a basis for my main loop. I have a separate thread running during loadup which loads all the textures, models etc. When I turn V-Sync on the loading on the other thread slows down dramatically. If I turn V-Sync off it loads much faster. This seems odd to me as I thought V-Sync would free up the other thread to run faster when it was on and not the other way around. Is this an expected result or have I made a mistake somewhere?
Does anyone have any insight into what might be causing the issue as I've been messing arround with thread priorities and they don't seem to make any difference.

The only thing that does help is if I sleep for a few miliseconds in the Main Update loop.

Thanks in advance for any help!

David

Sponsor:



Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS