Jump to content

  • Log In with Google      Sign In   
  • Create Account


quake 3 after compile .exe error


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
1 reply to this topic

#1 proed   Members   -  Reputation: 109

Like
0Likes
Like

Posted 25 September 2012 - 01:39 PM

Hi there,i works with visual std 11(2012)
.exe is compiling good,but after run of that .exe i have an error
with debugger i found dat :error at VM_Callcompiled;file vm_x86.c

#ifdef _WIN32
__asm  {
  pushad
  mov  esi, programStack;
  mov  edi, opStack
  call entryPoint
  mov  programStack, esi
  mov  opStack, edi
  popad
}
thr error at mov programStack, esi
whats wrong?thats native sdk,im not modified anything
also .exe from quake's 3 original distr is works

Edited by proed, 25 September 2012 - 01:43 PM.


Sponsor:

#2 caldiar   Members   -  Reputation: 701

Like
1Likes
Like

Posted 25 September 2012 - 01:49 PM

Try adding the following argument to the .exe on launch - "+set sv_pure 0"

You should also be compiling and using DLLs rather than the QVM files. Custom QVM code had always been buggy for me in the past and DLLs solved a lot of headaches.

To use the DLLs add the following arguments to the .exe on launch - "+set vm_game 0 +set vm_cgame 0 +set vm_ui 0"

Launching from the command line, it should all look like this: "./quake3.exe +set sv_pure 0 +set vm_game 0 +set vm_cgame 0 +set vm_ui 0". You can save that in a batch file and run it from the folder containing your quake3.exe file.

Hopefully that helps you out some. It's been a long while since I've worked on any Quake 3 stuff. Seriously brings back memories.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS