Jump to content

  • Log In with Google      Sign In   
  • Create Account


Blender UV mapping problem


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
4 replies to this topic

#1 KurtO   Members   -  Reputation: 210

Like
0Likes
Like

Posted 03 October 2012 - 12:07 PM

Hello!

When i uvmap a simple cube it all works with my export and my textcoord imports. The Model render correct with correct texture/positions.

as soon as i extrude the cube and do the same thing it fails.

I am making my game level by extruding the faces of a cube the whole time.

Is there a way to convert all my faces to a single mesh, that i after the conversion can UV map like my Cube when i first select new->cube.

My feeling is as soon as i alter/change my mesh the UV mapping is broken.

Any tips?

Sponsor:

#2 JTippetts   Moderators   -  Reputation: 7916

Like
0Likes
Like

Posted 03 October 2012 - 12:48 PM

If you're extruding a cube, then all your faces should already be a single mesh, so I don't really understand what your problem is there...

But yes, after extruding faces you do need to redo your UV unwrapping, since the newly generated faces won't have proper UV mappings. I recommend you play with the various UV unwrap modes in the 'u' menu. Smart UV Project is probably not what you want for rigid cubical geometry, since that has a tendency to be a tad messy; it's more for organic or highly complex meshes that would be a pain to unwrap by hand. Follow Active Quads tends to generate neater squares; however, it doesn't care about overlap, so many of the faces will be unwrapped on top of one another. Lightmap pack will generate neat squares from an extruded cube, with no overlap, but also with no particular attention paid to seams and orientation. It's usually only used for pre-bake lightmap UVs.

Basically, though, for any level geometry that is non-trivial, the best results will always be achieved by unwrapping by hand. You can make good use of the Project From View and Project From View (Bounds) options here; select some faces, orient the view, and project. Go into your UV map and hand tweak them as needed. Rinse and repeat. The "automatic" solutions for UV mapping tend to be less optimal, especially since you need to carefully place your UVs in order to make use of repeating and modular textures, and there really are few options other than hand unwrapping, especially for architectural features like level geometry.

#3 KurtO   Members   -  Reputation: 210

Like
0Likes
Like

Posted 03 October 2012 - 01:34 PM

I see, i thought that it would generate perfect fit just by unwrap mapping.
When i uv-map a simple cube i get the right coordinates for the texture in DirectX, but when i extrude a little bit i always get a diff and not matching textures.

when i use simple unwrap by hand with a cube the coordinates are working, but as soon as i use more complex mesh it don´t work.

and i dont understand why? it looks good when i render in Blender? (hey that rimes!)

#4 KurtO   Members   -  Reputation: 210

Like
0Likes
Like

Posted 03 October 2012 - 02:45 PM

Okay, now i have taken another approach.

I am using UV Editing and positioning all my faces at a certain position of the texture. This is great and i will use this method to hand position all my faces.

BUT, the offset don´t seem to work when exporting...

if i for example put a square face on the "head" of a human in an image, then the middle body is what is shown when i render the mesh in DirectX.
It feels like i am loosing like 25% in Y axis when exporting coordinates...

Does my texture has to be at a specific size? must it be square?

#5 KurtO   Members   -  Reputation: 210

Like
0Likes
Like

Posted 03 October 2012 - 02:57 PM

YEEEES!!!!

The V has to be INVERTED!!! Now it Works!

How cool is this! ONE big texture map to map all my faces against! Good for performance and easy on the time!
Now i have FULL control of my vertices becuase i export the mesh with my own exporter! =)

And i guess if i want bump mapping or specular i just have to make me a matching map against my main texture!
Then the job is allready done for bumps and spec, no need for mapping again! =) Huurrray!

Over and out!




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS