Jump to content

  • Log In with Google      Sign In   
  • Create Account

- - - - -

Debugger stopping at asISciptModule::Build()


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
1 reply to this topic

#1 Maeriden   Members   -  Reputation: 140

Like
0Likes
Like

Posted 04 October 2012 - 02:52 PM

Well, the issue is pretty simple: I'm trying to debug my code and when the debugger hits the call to module->Build() first the program closes itself, then the debugger stops itself too, with the message "The program is not being executed"

I'm still a real novice when it comes to debugging, and I started trying out AS only recently, so I'm wondering if there's anyone who can help me understand what's going on. I'm using C::B 10.05 and its debugger (which I believe is called DBG?).
I'm not posting info right now since I have no idea what could be relevan to the problem.

Sponsor:

#2 Andreas Jonsson   Moderators   -  Reputation: 3375

Like
0Likes
Like

Posted 04 October 2012 - 05:44 PM

If you run the application without debugging, does it pass the point where it stops when debugging?

I'm not familiar with Code::Blocks and it's debugger, but it sounds like it might be caused by the debugger not finding the debug symbols for the AngelScript library, and for some reason exits instead of continuing the debugging without them. Have you tried getting support from the Code::Blocks developers? Perhaps they might be able to help you figure out why the debugger stops like that.
AngelCode.com - game development and more - Reference DB - game developer references
AngelScript - free scripting library - BMFont - free bitmap font generator - Tower - free puzzle game




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS