Jump to content

  • Log In with Google      Sign In   
  • Create Account

Sketchup 8 Collada Export - Backfaces


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
1 reply to this topic

#1 PhillipHamlyn   Members   -  Reputation: 454

Like
0Likes
Like

Posted 08 October 2012 - 01:33 PM

I am playing with using Sketchup 8 and the large population of pre-built meshes and textures available through Google to fill in some content on my non-commercial project. I use Sketchup 8's Save to Collada option to generate me a useful XML output which I then parse into an indexed mesh.

My only issue is that Sketchup always has two faces per quad, there doesn't seem to be the concept of a back-face. Consequently all the meshes I export have two faces, of which I definitely dont want one of them. However I dont know of any way of excluding the back-faces, since I find it difficult to even define one - I "know" its the face that is "inside" the 3d mesh object, but other than looking at its Face Normal in relation to the objects centre point (doesn't work with non convex bodies particularly) I find it difficult to hit on an idea for excluding them.

Does anyone have any bright ideas ?

Sponsor:

#2 PhillipHamlyn   Members   -  Reputation: 454

Like
0Likes
Like

Posted 09 January 2013 - 03:59 PM

Just for reference - here was my solution.

 

When exporting from Sketchup 8 you have the option to "Export 2 Sided Faces" from the export options tab. Although you might not want 2 sided faces, its the only way to guarantee that all the faces you see in Sketchup are included in your export file - I've had incidences where failing to check this option gave me missing faces I could otherwise see in Sketchup.

 

Once you've exported both sides, just cull clock or counterclock as normal and the model will show correctly. It has more geometry that you really need, but it works Ok.






Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS