Jump to content

  • Log In with Google      Sign In   
  • Create Account


SSAO artifacts


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
2 replies to this topic

#1 EternalNewbie   Members   -  Reputation: 207

Like
0Likes
Like

Posted 12 October 2012 - 05:08 AM

Hi all

I'm trying to implement very basic ssao but get the following artifacts. I'm not using the normals and I'm using a simple filter with no noise here.
I've tried using a noise filter which helps remove them on the floor except when looking directly at them. However they seem to persist on the walls
and other objects.
Has anyone seen these sort of artifacts before? Any Idea how to get rid them?

Attached Thumbnails

  • SSAOArtefacts.jpg


Sponsor:

#2 johnchapman   Members   -  Reputation: 506

Like
0Likes
Like

Posted 12 October 2012 - 06:59 AM

It looks to me as though your sample kernel's radius is quite small, such that it's causing some erroneous occlusion on the floor where the triangles intersect. Try increasing the sample kernel radius to see if that alleviates the problem.

#3 EternalNewbie   Members   -  Reputation: 207

Like
0Likes
Like

Posted 12 October 2012 - 11:00 AM

Thanks tried changing the kernel size but this doesn't seem to make any difference.
Adding a minimum depth difference helps to remove the artifacts in some areas but as I move the camera it simply reappears at different depths.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS