Jump to content

  • Log In with Google      Sign In   
  • Create Account


'Completed' Pong Project; looking for Critique.


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
2 replies to this topic

#1 stitchs   Crossbones+   -  Reputation: 1275

Like
0Likes
Like

Posted 29 December 2012 - 09:02 PM

Hey guys,

I have been working on this for about a month and half now, with two weeks spent on the first iteration and the last 3-4 on changes suggested by this wonderful community.

 

I have worked my way through the the list and am now (in loose quotations) finished. I am pleased with what I have learned on the way, and how I will take some of it forward. I also realise that my code was nowhere near what it should have been and have revised much of it.

 

There are still some issues:

  • Hard-coded/cumbersome state machine in Game.h (to be revised in next project)
  • Ball sprite appearing white (this is one I could use some advice on)
  • Game over text being highlighted incorrectly
  • Lack of sound/save functionality.
  • Players should probably by local to Game.h and opposed to Arena.h

 

 

Could I get you guys to try it out, and have a gander at the code as some new feedback would be excellent to take into the next project. Please find this below.

 

I write this late and will probably think of extra things, and add them tomorrow.

 

Regards,

 

Stitchs.

Attached Files



Sponsor:

#2 BaneTrapper   Members   -  Reputation: 1109

Like
0Likes
Like

Posted 30 December 2012 - 02:31 PM

I tried it out.
Nice pong game you have here, but you should seriously consider capping FPS.
Also when paddle can overlap numbers (when up most in screen), could reduce the playable terrain size to make area just for tracking stats.
Difference paddle color from the text color. (Just recolor the image)

Also if it took you one and a half month for this, i would ask how many work hours did you do a day? or/and are you still learning?

EDIT:: That AI so strong, i almost lost was like 5-4. I love it, great for lol's.

Edited by BaneTrapper, 30 December 2012 - 02:37 PM.

Current projects:
The Wanderer, 2d turn based rpg style game

www.gamedev.net/topic/641117-check-up-the-wanderer/


#3 rip-off   Moderators   -  Reputation: 7651

Like
2Likes
Like

Posted 30 December 2012 - 07:07 PM


This reply is on the same lines as my earlier analysis. Many of the suggestions are stylistic in nature, but I believe that there are certain styles that are bug prone, difficult to read or that cause confusion. What I mean is that most of them are somewhat subjective, the important thing is that you've completed your project and are happy with it.
 
Here are some notes from a short review of the code. Where possible, I highlight a specific piece of code, but sometimes the underlying issue is present in multiple locations.
 
</div>
<div>// np prefix to represent stack objects.</div>
<div>Arena npPongArena;</div>
<div>GUIMenu npMainMenu, npGameOverMenu;</div>
<div>
 
Member variables that are not pointers are not necessarily "stack" objects. After all, they may be located on the heap if the enclosing object(s) are dynamically allocated. I would question the need for a special prefix to such objects, since you don't appear to use it with builtin types or enumeration values.
 
</div>
<div>int Game::RunGame()</div>
<div>{</div>
<div>    sf::RenderWindow gameWindow_(/ * ... */);</div>
<div>}</div>
<div>
Code conventions that use trailing underscores usually reserve them for member variables, not automatically allocated objects like this. 
Such a pre/post fix should have a specific reason. The point is not to decorate every symbol. It should highlight exceptional cases, such as pointers, references, member variables, global or static data. Automatic variables and value parameters are "easy", their declarations are usually visible, and they are more likely to stay in one's mind than some of the more complex examples I listed above.
 
</div>
<div>MyHelper::FloatToString(frameRate_, true)</div>
<div>
Quick test: what does FloatToString do when passed false? Avoid boolean parameters where possible, particularly where the input is a literal. Better would be to use a enumeration of the desired behaviour:
</div>
<div>enum FloatFormatting {</div>
<div>    FloatFormattingNone,</div>
<div>    FloatFormattingTruncate</div>
<div>};</div>
<div> </div>
<div>MyHelper::FloatToString(frameRate_, MyHelper::FloatFormattingTruncate);</div>
<div>
But even still I would advise against trying to overload these two distinct behaviours into the same function. Let the caller use IntToString if necessary:
</div>
<div>int truncatedFrameRate = static_cast<int>(frameRate_);</div>
<div>std::string whatever = IntToString(truncatedFrameRate);</div>
<div>
In this specific case, you might avoid this by not storing the frame rate as a float. Calculating the frame rate every single frame can lead to the frame rate being difficult to read if your frame times fluctuate. What I tend to do in my games is to maintain a frame counter and a timer, and when the timer exceeds a second I update the FPS string value.
 
</div>
<div>GUIMenu::GUIMenu(sf::Vector2i position, int numOptionsIn, int firstSelectable)</div>
<div>
Mixing the "options" container with non-selectable options is confusing. I'd probably design this class to contain an (optional) "description" - which is text that would be printed above the options but is not considered selectable.
 
Alternatively, you could have the concept of a "MenuEntry", which might be selectable by default, but the caller can create a non-selectable instance too. This would allow you to, for example, have a main menu with "disabled" entries, such as a "Load Game" entry which is not selectable (and probably visually de-emphasised) until the user has created a save game:
</div>
<div>class MenuEntry {</div>
<div>public:</div>
<div>     enum EntryState {</div>
<div>         Disabled,</div>
<div>         Enabled,</div>
<div>     };</div>
<div> </div>
<div>     MenuEntry(const std::string &name, EntryState state = Enabled);</div>
<div> </div>
<div>     // ...</div>
<div>};</div>
<div> </div>
<div>class Menu {</div>
<div>public:</div>
<div>    Menu(/* ... */);</div>
<div> </div>
<div>    void addEntry(const MenuEntry &entry);</div>
<div> </div>
<div>    // ...</div>
<div>};</div>
<div>
 
</div>
<div>// Loop through keys, without the need to check the event queue because</div>
<div>// I am using the Windows' GetInput(). I am unable to check with the</div>
<div>// the queue as this method is not called in the event polling loop.</div>
<div>// Instead, I just input the counter into the Code structure and see if</div>
<div>// it matches, in order to update curButtonState_.</div>
<div>// TODO: need to include a boolean check to see if a key has been pressed, before looping on every go.</div>
<div>
Consider having another function, HandleInput() or HandleEvent(), which can be called as part of the event polling loop. Right now, your polling loop discards all the events, and you go to great pains elsewhere to reconstruct this information.
 
</div>
<div>sf::Sprite& Paddle::GetSprite()</div>
<div>{</div>
<div>    if(spriteLoaded_)</div>
<div>    {</div>
<div>        return paddleSprite_;</div>
<div>    }</div>
<div>}</div>
<div>
This is a bug. All code paths should always return a value. You need to heed compiler warnings about this. If your compiler doesn't warn you about this, turn the warnings up as far as they will go. Ideally, use the compiler switch "treat warnings as errors". 
 
</div>
<div>void Paddle::OnWallCollision(sf::Vector2f &colAreaPosition, sf::Vector2f &colAreaDimensions)</div>
<div>{</div>
<div>    // ...</div>
<div>    return;</div>
<div>}</div>
<div>
This is really minor, but it is not necessary to put an explicit return as the last line in a function. Leaving one in flags in my mind because it makes me think that this should be nested in a condition or loop that you have forgotten.
 
</div>
<div>if(!paddleImage_.LoadFromFile(filename))</div>
<div>{</div>
<div>    // Handle error...</div>
<div>}</div>
<div>else</div>
<div>{</div>
<div>    // Handle success...</div>
<div>}</div>
<div>
When you're covering both cases, it is easier to read the code if you write the "positive case" first:
</div>
<div>if(paddleImage_.LoadFromFile(filename))</div>
<div>{</div>
<div>    // Handle success ...</div>
<div>}</div>
<div>else</div>
<div>{</div>
<div>    // Handle error...</div>
<div>}</div>
<div>
 
</div>
<div>static sf::Image paddleImage_;</div>
<div>static bool imageLoaded_;</div>
<div>
This is fine for a small game. For larger games, you'll probably want to avoid relying on global state. Due to this state, it is actually difficult to unit test the Paddle class.
 
Also, having a member function LoadSprite() which simultaneously interacts with both the static class state and the instance state is confusing and suprising. It might be better to consider a static member function to initialise the static data, and then a member function to "apply" this to the Paddle instances.
 
Your Paddle code has lots of branches for handling the presence/absence of a loaded image. One alternative to this is to use a polymorphic type. Consider:
</div>
<div>class PaddleRenderer {</div>
<div>public:</div>
<div>    virtual ~PaddleRenderer() {}</div>
<div> </div>
<div>    virtual void render(const Paddle &paddle) = 0;</div>
<div>};</div>
<div> </div>
<div>class PrimitivePaddleRenderer : public PaddleRenderer {</div>
<div>public:</div>
<div>    // Fill a rectangle at the paddle's position with the necessary colour</div>
<div>    virtual void render(const Paddle &paddle);</div>
<div>};</div>
<div> </div>
<div>class ImagePaddleRenderer : public PaddleRenderer {</div>
<div>public:</div>
<div>    ImagePaddleRenderer(const sf::Image &image);</div>
<div> </div>
<div>    // Fill a rectangle at the paddle's position with the necessary colour</div>
<div>    virtual void render(const Paddle &paddle);</div>
<div>     </div>
<div>private:</div>
<div>    // Maybe you need a sf::Sprite and/or a sf::Image here, I'm not too familiar with SFML</div>
<div>};</div>
<div> </div>
<div>// Factory function</div>
<div>std::unique_ptr<PaddleRenderer> createRenderer() {</div>
<div>    sf::Image image;</div>
<div>    if(image.LoadFromFile("images/paddle")) {</div>
<div>        return std::unique_ptr<PaddleRenderer>(new ImagePaddleRenderer(image));</div>
<div>    }</div>
<div> </div>
<div>    // It would be nice to log the I/O error here...</div>
<div>    return std::unique_ptr<PaddleRenderer>(new PrimitivePaddleRenderer());</div>
<div>}</div>
<div>
 
</div>
<div>void OnWallCollision(sf::Vector2f &colAreaPosition, sf::Vector2f &colAreaDimensions);</div>
<div>
A position and dimensions? Sounds like a rectangle... Actually you do have a comment to this effect in Ball.h
 
</div>
<div>//Paddle reference?</div>
<div>Paddle pPaddle_;</div>
<div>
This is inconsistent with the remainder of your coding convention.
 
</div>
<div>Player::Player(/* ... */, Paddle &paddleIn)</div>
<div>{</div>
<div>    // ...</div>
<div>    pPaddle_ = paddleIn;</div>
<div>}</div>
<div>
You are copying the paddle here. This isn't necessarily wrong, but it is surprising. I hope that Paddle, and all its (recursive) members correctly handle being copied.
 
</div>
<div>enum Direction2D</div>
<div>{</div>
<div>    DirNone, // Default direction</div>
<div>    DirUp, // Up</div>
<div>    DirDown, // Down</div>
<div>    DirLeft, // Left</div>
<div>    DirRight, // Right</div>
<div>    DirAxisX, // Represents the horizontal axis</div>
<div>    DirAxisY // Represents the vertical axis</div>
<div>};</div>
<div>
This appears to be two distinct enumerations hiding inside the same one. I'd prefer separate Direction and Axis enumerations.
 
</div>
<div>class Arena</div>
<div>{</div>
<div>    // ...</div>
<div>    sf::Rect<float> arenaArea_;</div>
<div>    Ball npBall;</div>
<div>    std::vector<Player> players;</div>
<div>};</div>
<div>
I can't see any consistency in the naming convention here. sf::Rect<float>, Ball and std::vector<Player> are all user defined value types. These are all member variables. Why don't they all have a trailing underscore? Why don't they all have the "np" prefix?





Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS