Jump to content

  • Log In with Google      Sign In   
  • Create Account

Interested in a FREE copy of HTML5 game maker Construct 2?

We'll be giving away three Personal Edition licences in next Tuesday's GDNet Direct email newsletter!

Sign up from the right-hand sidebar on our homepage and read Tuesday's newsletter for details!


We're also offering banner ads on our site from just $5! 1. Details HERE. 2. GDNet+ Subscriptions HERE. 3. Ad upload HERE.


[Resolved] Render Target & Alpha Blending


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
No replies to this topic

#1 reaperrar   Members   -  Reputation: 134

Like
0Likes
Like

Posted 21 January 2013 - 11:59 PM

FINAL EDIT:

Resolved... just needed to learn how alpha blending works in-depth. I should have had:
oBlendStateDesc.RenderTarget[a].DestBlendAlpha = D3D11_BLEND_ZERO;
...set to D3D11_BLEND_ONE to preserve the alpha.

When rendering to the backbuffer once the problem would not be noticed as the colours blend normal and that is the final output. When rendering to the texture the same thing applies, just then rendering the texture to the backbuffer the incorrect alpha plays a role in incorrectly blending the texture into the backbuffer.

I then ran into another issue where the alpha seemed to be decreasing. This is because the colour is blended twice, for example...

Source.RBGA = 1.0f, 0.0f, 0.0f, 0.5f
Dest.RGBA = 0.0f, 0.0f, 0.0f, 0.0f

Render into texture...
Result.RGB = Source.RBG * Source.A +  Dest.RGB * (1 - Source.A) = 0.5f, 0.0f, 0.0f
Result.A = Source.A * 1 + Dest.A * 1 = 0.5f

Now...
Source.RBGA = 0.5f, 0.0f, 0.0f, 0.5f
Dest.RGBA = 0.0f, 0.0f, 0.0f, 0.0f

Render into backbuffer...
Result.RGB = Source.RBG * Source.A +  Dest.RGB * (1 - Source.A) = 0.25f, 0.0f, 0.0f
Result.A = Source.A * 1 + Dest.A * 1 = 0.5f

To resolve this, when rendering the texture into the backbuffer I use the same blendstate but change the SrcBlend to D3D11_BLEND_ONE so the colour is not blended twice.

Hopefully this helps anyone else having a similar problem....
EDITEND

 

When rendering to a render target there doesn't seem to be any alpha blending happening between what is being rendered and what is being render with the render target background.

 

I've disabled the depth and stencil testing (EDIT: rendering in 2D)

 

I've enabled alpha blending with the following:

 

D3D11_BLEND_DESC oBlendStateDesc;

oBlendStateDesc.AlphaToCoverageEnable = 0;
oBlendStateDesc.IndependentBlendEnable = 0; //set to false, dont need loop below... but just incase

for (unsigned int a = 0; a < 8; ++a)
{
	oBlendStateDesc.RenderTarget[a].BlendEnable = 1;
	oBlendStateDesc.RenderTarget[a].SrcBlend = D3D11_BLEND_SRC_ALPHA;
	oBlendStateDesc.RenderTarget[a].DestBlend = D3D11_BLEND_INV_SRC_ALPHA;
	oBlendStateDesc.RenderTarget[a].BlendOp = D3D11_BLEND_OP_ADD;
	oBlendStateDesc.RenderTarget[a].SrcBlendAlpha = D3D11_BLEND_ONE;
	oBlendStateDesc.RenderTarget[a].DestBlendAlpha = D3D11_BLEND_ZERO;
	oBlendStateDesc.RenderTarget[a].BlendOpAlpha = D3D11_BLEND_OP_ADD;
	oBlendStateDesc.RenderTarget[a].RenderTargetWriteMask = D3D11_COLOR_WRITE_ENABLE_ALL;
}

// Create the blend state from the description
HResult = m_poDevice->CreateBlendState(&oBlendStateDesc, &m_poBlendState_Default);

m_poDeviceContext->OMSetBlendState(m_poBlendState_Default, nullptr, 0xffffff);

 

If rendering to the backbuffer alpha blending works and I am not changing the blend state.

When rendering the render target texture to the backbuffer the alpha blending works fine as well.

 

Anyone know how I can fix?

 

EDIT: It seems it just ignores whatever pixel is inside the render target texture already and just overwrites it with what is rendering in. The alpha is preserved though, so when I render the texture to the screen I see my sprites on the texture blending with the backbuffer (they just dont appear blended with each other within the texture).

 

EDIT: I'm under the impression that I'm missing an important step to get blending working that you wouldn't normally take unless not rendering to the backbuffer.

 

EDIT: Since I'm getting no replies I'm thinking that there are no extra steps, that the alpha blending should work & i should keep going over what I have... can anyone confirm this?

 

EDIT: If I set AlphaToCoverageEnable to true it blends, but looks terrible. That at least confirms it is using the same blend state... just works differently depending on when rendering to backbuffer or a texture : /

 

Here's some visualization...

textt.png

 

1. Rendering to backbuffer - AlphaBlending enabled.
2. Rendering to texture - AlphaBlending enabled.
3. Rendering to backbuffer - AlphaBlending disabled.
4. Letter T taken from the font file

*When rendering with AB disabled, the letters match exactly (compare 4 & 3)
*When rendering to the backbuffer with AB enabled, the letters render slightly (hardly noticeable) washed out but still blend (compare 4 & 1)
*When rendering to a texture with AB enabled, the letters render even more noticeably washed out while not blending at all. (compare 4 & 2)

Not sure why the colours are washed out with alpha blending enabled... but maybe its a clue?

 

EDIT:

If I clear the render target texture to say... 0.0f, 0.0f, 1.0f, 1.0f (RGBA, blue)... this is the result:

text22.png

 

Only the pixels with alpha > 0.0f & < 1.0f blend with the colour. Another clue but I have no idea how to resolve this issue...


Edited by reaperrar, 24 January 2013 - 06:26 PM.


Sponsor:



Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS