Jump to content

  • Log In with Google      Sign In   
  • Create Account


[SDL] SDL_mixer not working (ubuntu)


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
2 replies to this topic

#1 EvanClark   Members   -  Reputation: 130

Like
0Likes
Like

Posted 25 January 2013 - 07:28 AM

Hello i have been working with sdl for a while but this is my first time
using sound. However when i try to install SDL_Mixer with this
following command

 

sudo apt-get install ibsdl-mixer1.2-dev
 

 

it all installs perfectly and such but then when i run a program (made
by lazy foo) it returns an error "SDL_types not found" how would i be
able to fix this?



Sponsor:

#2 __SKYe   Members   -  Reputation: 981

Like
0Likes
Like

Posted 25 January 2013 - 07:49 PM

I don't use Ubuntu, and never used SDL, but if it installed correctly, maybe you have to add the SDL_Mixer directory to your project, or something along those lines.

 

What is your IDE and language? Does your program without sound work fine? Have you installed any other SDL package the same way, and it worked?

Further information could be helpful.



#3 ultramailman   Prime Members   -  Reputation: 1561

Like
0Likes
Like

Posted 25 January 2013 - 08:43 PM

Try linking with sdl_mixer, if you haven't. So you would add an -lsdl_mixer command line option to gcc, and that way it will link to the sdl_mixer library.




Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS