Jump to content

  • Log In with Google      Sign In   
  • Create Account

Interested in a FREE copy of HTML5 game maker Construct 2?

We'll be giving away three Personal Edition licences in next Tuesday's GDNet Direct email newsletter!

Sign up from the right-hand sidebar on our homepage and read Tuesday's newsletter for details!


We're also offering banner ads on our site from just $5! 1. Details HERE. 2. GDNet+ Subscriptions HERE. 3. Ad upload HERE.


ODE problem with Hinge2 joint


Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.

  • You cannot reply to this topic
No replies to this topic

#1 Vaclav   Members   -  Reputation: 136

Like
0Likes
Like

Posted 09 February 2013 - 08:18 AM

I've been trying to create a car model with the ODE physics engine.

I set the rear wheels to always face forward parallel with the chassis:



dJointSetHinge2Param ( joint, dParamLoStop, 0.0);
dJointSetHinge2Param ( joint, dParamHiStop, 0.0);

When the car is moving forward it's fine but when the car turns the rear wheels get turned somehow. I control only the front wheels, it's not four wheel steering.

I've tried to set other parameters of the Hinge2 joint as well like dParamERP and CFM, dParamStopERP and CFM or dParamBounce but they had no effect on this, I've also tried number 1 and 2 from these. (See in the ODE manual: Joint types -> Parameter Functions.)

 

Here are two screenshots to see the problem better:

Spoiler

 

Thank you for your help.



Sponsor:



Old topic!
Guest, the last post of this topic is over 60 days old and at this point you may not reply in this topic. If you wish to continue this conversation start a new topic.



PARTNERS